How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3663
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

The tack. On my Meredes is doing Strang things, when the

Customer Question

The tack. On my Meredes is doing Strang things, when the engine is idling it will suddenly come on increasing the RPMBYABOUT 200 then go back to normal engine RIM WITH the tack showing 0 RPM.
Submitted: 4 months ago.
Category: Mercedes
Expert:  Pete replied 4 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

If the engine is not running poorly or stalling out with this tach issue this can indicate a fault with the tach itself needing replaced.I have seen the tach fail or act up in the past before with it needing removed and replaced in most all cases.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 4 months ago.
York missed something in his question the engine is not running properly when the tack comes on the engine seeds up about 200 RPM AND runs good, it runs OK when the tack is not working, but it is real sluggish. I am sue there is a bad connection some where I just can't industry it. There is a test point called for in the wiring diagram but I can't find it.
Expert:  Pete replied 4 months ago.

O.k.,your model uses an engine rpm sensor located at the bottom of the rear side of the engine as shown here.

I dont have the testing info on this here but if this sensor is acting up sending incorrect signals intermittently this wil cause the tach issue as well as the rpm gauge issues here.I suspect this sensor is failing needing replaced which can be common.

Let me know if you need anything else and feel free to rate my help here as this is how I receive credit for my time.

Thanks Pete

Customer: replied 4 months ago.
Pete is NOT a mechanical he is a parts changer!
Expert:  Pete replied 4 months ago.

I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.

Thanks Pete

Expert:  Lou P. master tech replied 4 months ago.

Hello, sorry for the delay, are you still needing assistance? this is an odd issue so it may take a little time to fix but i will do what i can to help you. Let me know if you want to proceed, Lou P.

Related Mercedes Questions