How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Mercedes
Satisfied Customers: 34171
Experience:  ASE Certs.
7276279
Type Your Mercedes Question Here...
Ron is online now
A new question is answered every 9 seconds

I have a clk 200 compressor from 2009. i recently replaced

Customer Question

i have a clk 200 compressor from 2009. i recently replaced the battery because it died on me in traffic. With the new battery the light still comes on and today, the car switched off on me. Now this problem comes and goes, sometimes there are no warning lights and the car does a full journey very well. I have read on forums that it could be faulty fuses on the front seat control that drain the battery.
JA: Have you tested the battery? Is the battery fluid low?
Customer: what could it be
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: i haven't tried anything yet.
JA: Anything else you think the mechanic should know?
Customer: the wipers go haywire once in a while, like they don't consider the amount of rain. they just go to full speed even during light drizzles.
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Mercedes Mechanic about your situation and then connect you two.
Submitted: 8 months ago.
Category: Mercedes
Expert:  Ron replied 8 months ago.

Hello, my name is ***** ***** I am a professional here at Just Answer. I have noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

John, the battery light dose not come on if you have a bad battery but instead it comes on when the alternator has a problem. If the new battery is not hold a charge after it was replaced then you are very likely looking at a charging system concern usually due to a failing alternator. The place to start is to have the charging system tested , the normal charging rate on a properly working alternator should be right at 14 volts at the battery with the engine running.