How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Mercedes Mechanic
Category: Mercedes
Satisfied Customers: 24656
Experience:  Over 15 years experience as a Mercedes dealer technician
14928985
Type Your Mercedes Question Here...
Pete is online now
A new question is answered every 9 seconds

Have 2007 MB GL 450. Radio goes on, plays few minutes and

Customer Question

Have 2007 MB GL 450. Radio goes on, plays for a few minutes and goes off. Comes back on every now and then. Radio was replaced, same issue. Amplifier replaced same issue.
JA: Have you checked the fuses?
Customer: The radio comes on, the CD player will also play, and after a few minutes the sound stops. Then it may come on 10 minutes later or 30 minutes later.
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Replaced the radio with a new one, same thing happens. Replaced the amplifier, same thinghappens.
JA: Anything else you think the mechanic should know?
Customer: no, just don't know why the sound just stops sporadically
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Mercedes Mechanic about your situation and then connect you two.
Submitted: 5 months ago.
Category: Mercedes
Expert:  Pete replied 5 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

If anything after market has been installed at all in some cases this can cause this type of fault here needing either removed or re wired properly to correct this fault.If nothing after market has been installed at all on your model let me know so we can continue from here.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete