How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 4087
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

I have a 98 sl500, I didn't run it over the winter and the

Customer Question

I have a 98 sl500, I didn't run it over the winter and the battery died, I jumped it and it ran but the battery drained again when I parked it. I bought a new battery and now the car cranks but does not start. Idea's ?
JA: Does the engine turn over? How old is the battery?
Customer: yes it turns over and the battery is new.
JA: Are you hoping to fix this yourself?
Customer: yes
JA: Great! What have you tried so far?
Customer: I read where it could have been the crankshaft sensor, so I just replaced it and still the same issue.
JA: Is there anything else the Mercedes Mechanic should be aware of about your Mercedes?
Customer: No
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Mercedes Mechanic about your situation and then connect you two.
Submitted: 9 months ago.
Category: Mercedes
Expert:  Lou P. master tech replied 9 months ago.

Hello, looking over your story i have to ask , at any time was the battery hooked up wrong or jumper cables used incorrectly?

Customer: replied 9 months ago.
Not that I am aware
Expert:  Lou P. master tech replied 9 months ago.

ok so at this point lets start at the battery, make sure the cables are 100% tight and cannot be twisted by hand, then close the door and lock and unlock the car and then see if it will start.

Customer: replied 9 months ago.
ok give me a min
Expert:  Lou P. master tech replied 9 months ago.

no problem i am in no hurry

Customer: replied 9 months ago.
No it did not start
Expert:  Lou P. master tech replied 9 months ago.

ok, so now we need to know if we are missing fuel or spark, at the front right of the engine on the fuel rail there is a small black plastic cap that unscrews and has a valve under it like a tire valve, press the center in carefully and see if fuel comes out. also do you hear the fuel pump buzz when turning the key on?

Customer: replied 9 months ago.
When I turn the key I can hear the hum, I will need a little clarification on the fuel rail location.
Expert:  Lou P. master tech replied 9 months ago.

here you go

Customer: replied 9 months ago.
Found it and gas came out
Expert:  Lou P. master tech replied 9 months ago.

ok so then crank it one more time and reconfirm and then we can move on

Customer: replied 9 months ago.
A little diff than your pic, but gas came out.
Expert:  Lou P. master tech replied 9 months ago.

my pic was v6 same engine just minus 2 cylinders.

ok so how many ignition keys do you have?

Customer: replied 9 months ago.
It seemed like it wanted t o start, but didn't. Is there anything like a reset for the computer?
Customer: replied 9 months ago.
1 key
Expert:  Lou P. master tech replied 9 months ago.

no reset, other than locking and unlocking to see if it was because of the alarm . ok do you have starter fluid?

Customer: replied 9 months ago.
I'll check
Customer: replied 9 months ago.
No on the starter fluid
Expert:  Lou P. master tech replied 9 months ago.

ok, well, we need to know if we are missing fuel or spark. so can you get some? and maybe rent a scan tool from autozone to see if we have any codes to work off of, we need to determine if it is a security issue or sensor issue. also if you want to do a precheck, you can check all the fuses in the car, maybe one popped.

Customer: replied 9 months ago.
ok, how do I get back to you? Just leave this window open?
Expert:  Lou P. master tech replied 9 months ago.

yes you can reply here anytime, copy and paste the address at the address bar or bookmark this page. if i dont hear from you i will try and contact you.

Customer: replied 9 months ago.
ok, it started with the starter fluid, I turned the car off after 30secs and it wouldn't start on its own. Hit it again with fluid and it started but when I hit the gas it died again.
Expert:  Lou P. master tech replied 9 months ago.

ok so the module is not injecting fuel, give it a small shot and see how long it runs on its own.

Expert:  Lou P. master tech replied 9 months ago.

i find it hard to think you have a failed part after just a battery replacement, i have to leave for a bit. i will opt out so another expert can keep you on track. i will check back on the chat later to see how you are progressing and if i can advise of any repairs.

Customer: replied 9 months ago.
ok hit it with fluid and it ran about 3 mins and died.
Customer: replied 9 months ago.
Just went and checked with a code reader and came back zero. Turned the key and it started right up without the use of fluid, ran a few mins and died, wont restart.
Customer: replied 9 months ago.
Hit the MAF sensor with cleaner, same results
Expert:  Lou P. master tech replied 9 months ago.
Ok I am back. Sounds like the fuel pump is not working correctly. What is your fuel level? You will need to do a fuel pressure check to see what the pressure is when you first turn the key on and also the pressure when cranking and how long it holds pressure when the key is shut off. That all will determine if the fuel pump is good or not.