How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Mercedes
Satisfied Customers: 21572
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your Mercedes Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I have a 2003 c240 4 matic the a/c 't work. My code read

Customer Question

I have a 2003 c240 4 matic the a/c don't work. My code read was able to read the code and I gotP20D0-008
The air conditioning request an implausible fan Output. Check suction fan (P1999)I have never seen this before and am wondering what this means. Any help would be great.
Submitted: 6 months ago.
Category: Mercedes
Expert:  sprinkles08 replied 6 months ago.

Hello and welcome to JustAnswer!

This code sets when a fan speed of 255% or more has been requested and isn't likely related to the a/c not blowing cold, this is likely a control head issue but I expect it's erroneous.

I assume the blower motor works but the a/c does not blow cold?

If that's the case, does the compressor engage?

Customer: replied 6 months ago.
that is correct the blow works fine but I get no cold air. Get heat for winter and warm air for the summer. Now I have never heard it engage and I was told this is do to the little yellow light on the ac button always being on. Now I also got Multiple Other codes but my read just tells me the p0xx-xx number it has no idea what they are and I couldn't find them on the Internet either. I can give them to you if they may help.
Expert:  sprinkles08 replied 6 months ago.

If you have the other codes I'll definitely take a look at them.

Customer: replied 6 months ago.
I have:
P20CD-128
P20CD-001
P203A-128
P203A-008
P20D0-128
P20D0-008
now I don't know how old some of these are or how long they have been stored, but my car runs great with no problems expect no a/c.
Expert:  sprinkles08 replied 6 months ago.

Can you clear the codes, operate the a/c and see if any of these set again?

Customer: replied 6 months ago.
I was able to clear the codes none of them have returned at all. The AC off light is still on and I still have no ac. On the other had not once did the compressor trun on. The system is holding a charge at around 40 psi.
Expert:  sprinkles08 replied 6 months ago.

40 PSI without the compressor running? The system is mostly discharged if you have 40 PSI static pressure. The compressor won't turn on if pressure is too low, the first thing that should be done is properly charge the system.

Customer: replied 6 months ago.
Attached is a pic of my gauge I'm not sure what the proper charge pressure is for this car. I was just going by the lines on the gauge
Expert:  sprinkles08 replied 6 months ago.

That's for use when the compressor is running. If that's your static pressure then the system is near empty.

Customer: replied 6 months ago.
That's my static pressure as of right now. What should my static pressure be when the system is full?
Expert:  sprinkles08 replied 6 months ago.

It will be very close to ambient temperature with the engine cold.

Customer: replied 6 months ago.
I'm up to about 72psi and still the compressor has not come on.
Expert:  sprinkles08 replied 6 months ago.

You won't be able to charge the system properly without a recovery machine or without the compressor running (charging by pressure alone still isn't accurate though).

Do you have a scan tool to monitor data?

Customer: replied 6 months ago.
I do what do I need to look at?
Expert:  sprinkles08 replied 6 months ago.

Does it show the compressor is being commanded on?

Have you checked for power at the clutch connector with the engine running and a/c on?

Related Mercedes Questions