How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 4064
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

Mercedes C300: I have a 2010 c300 Mercedes Benz it want crank....all

Customer Question

I have a 2010 c300 Mercedes Benz it want crank....all the lights work and radio but no horn and new battery
Submitted: 9 months ago.
Category: Mercedes
Expert:  Lou P. master tech replied 9 months ago.
Hello, there are quite a few issues that can cause this, sometimes we can figure this out without a scan tool, but keep in mind there is a possibility it may need towed to a shop. can you tell me how this started and if you replaced any parts?
Customer: replied 9 months ago.
It started with the key not working at times..I would have to remove the key then lock and unlock the doors reinsert the key and the car would start
Expert:  Lou P. master tech replied 9 months ago.
ok how many keys do you own?
Customer: replied 9 months ago.
2
Expert:  Lou P. master tech replied 9 months ago.
ok good and you tried both keys?
Customer: replied 9 months ago.
same thing with both keys
Expert:  Lou P. master tech replied 9 months ago.
ok, so open the fuse box cover on the driver side of the engine bay, turn the ignition key on, use a test light and test each fuse for power, if i am right you will have a good majority without power indicating circuit 15 (key on power) is NOT active. if this is the case we need to swap the circuit 15 relay with another relay to see if the relay is the issue, if not then the issue is the ignition switch. let me know what fuses do not have power and i can then check the diagram to confirm. Lou p.
Customer: replied 9 months ago.
All fuse's were good
Expert:  Lou P. master tech replied 9 months ago.
explain what you mean by good?
Customer: replied 9 months ago.
No bad fuses all working they all light up
Expert:  Lou P. master tech replied 9 months ago.
OK so far so good, next we need to swap the starter relay to see if it cranks. ill get you the location
Expert:  Lou P. master tech replied 9 months ago.
ok the green relay is the starter relay when you pick it up on the fuse box you will see the letter M so you know you have the correct one. you need to use a test light and a small wire and make sure you have power at 2 of the 4 pins on the fuse block where the relay goes to ,