How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, Mercedes Technician
Category: Mercedes
Satisfied Customers: 53478
Experience:  Bosch Certified Master Tech. Over 35 years experience.
13230946
Type Your Mercedes Question Here...
Marty is online now
A new question is answered every 9 seconds

2000 e320 sport model and lights on while driving then stopped

Customer Question

2000 e320 sport model and lights on while driving then stopped at gas station and won't start won't even click over
Replaced stop lamp switch with extra i had in car
Submitted: 9 months ago.
Category: Mercedes
Customer: replied 9 months ago.
Battery voltage 12.4 just tested
Customer: replied 9 months ago.
Fuses check all good ecu fuse k40 relay???
Expert:  Marty replied 9 months ago.
Hi, welcome to Just Answer. My name is***** you still need help with this?
Customer: replied 9 months ago.
Yes i do the key can go in ignition and it will not shift out of park.. nor will it start when i put it in neutral with the shift flap
Customer: replied 9 months ago.
I haven't checked voltage off battery when trying to turn it over
Customer: replied 9 months ago.
I have although had some problems with the battery
Customer: replied 9 months ago.
Abs esp lights came on then it was sluggish then i stopped at gas station and then it didn't turn crank in position 3
Expert:  Marty replied 9 months ago.
Sorry about the wait I was offline last night when you replied. Have you checked the fuses in the K40 relay? The relay is located in the passenger side module box under the hood back near the hood hinge.
Customer: replied 9 months ago.
Is it similar to the older Mercedes ovp relay ?? 10 amp
Customer: replied 9 months ago.
Ok 10 amp fuse blown. .got a new 10 amp started up..abs and esc light on ..did the left right to clear out codes.. turned off and tried restart ... no start fuse blown again .. any ideas?
Customer: replied 9 months ago.
Cooling fan in ecu compartment? ? Do you know who would or where i would get a new one along with procedures?
Expert:  Marty replied 9 months ago.
Yes the most likely cause of the fuse blowing is the module box blower motor. You can disconnect the blower motor for now and see if the fuse still blows. I've attached some instructions below for accessing the blower motor. The blower motor is not that critical to the operation of the car or for the cooling of the modules. In my opinion you can just disconnect the motor. Let me know if you need anything else. Please remember to rate my service in order for the website to pay me for helping you.Marty
Expert:  Marty replied 9 months ago.
Hi, I'm just following up with you on the Mercedes. How are you doing? Did you get it figured out?