How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3721
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

S -350: Paul, I was driving my S-350 2012 model then climbed

Customer Question

Hi Paul,
I was driving my S-350 2012 model then climbed a bump and after some seconds, run flat, esp, abs, traction sign just popped on my dashboard. So i turned the engine off and on then it disappeared then after a while, it came back on. What could be the problem pls
Submitted: 7 months ago.
Category: Mercedes
Expert:  Lou P. master tech replied 7 months ago.
Hello, my name is ***** ***** am preparing a answer for you now
Expert:  Lou P. master tech replied 7 months ago.
Ok, your traction system (ESP,ABS,RUNFLAT) are all tied into the same system, based on what you stated happened it tells me that a sensor was damaged , you have a sensor at each wheel and they can wear and due to the up and down motion of the suspension over time and the bump you encountered may have just been the final nail in the coffin, you will have to have the codes read to see what sensor is the culprit, they are easy to change so a shop should not charge much to do it, hope this helps. Lou P.

Related Mercedes Questions