How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, Mercedes Technician
Category: Mercedes
Satisfied Customers: 53150
Experience:  Bosch Certified Master Tech. Over 35 years experience.
13230946
Type Your Mercedes Question Here...
Marty is online now
A new question is answered every 9 seconds

I replaced my alternator on my 2007 w221 s550, my voltage is

Customer Question

I replaced my alternator on my 2007 w221 s550, my voltage is at 11.7 ob the dash ... i believe i blew the fuse for the alternator but cant find it.. where would the fuse be? I looked online and it says on the passenger side by the starter battery but i dont see any 200 amp fuses there
JA: Lots of things can cause problems with the battery. The Mercedes Mechanic will know what to do. Are you hoping to fix this yourself?
Customer: Yes.. the new alternator is already in... car voltage remains the same while off and running.. assuming the fuse is blown and not letting the new alternator charge the system so its running on the battery
JA: Great! What have you tried so far?
Customer: Alternator and both batteries are new
JA: Is there anything else important you think the Mercedes Mechanic should know about your Mercedes?
Customer: Its a amg sport package w221 with the nightvision feature... the alternator it requires is a 220 amp not a 180amp
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Mercedes Mechanic about your situation and then connect you two.
Submitted: 7 months ago.
Category: Mercedes
Customer: replied 7 months ago.
Also the battery indicator on the dash would come on periodically before replacing the alternator and the check engine light came on as well after connecting both batteries back up, but the red battery indicator hasnt cane back up even though the ub voltage is at 11.6
Expert:  Matt C. replied 7 months ago.
Hello, I would like to see if I can help you with this. The fuse for the alternator is located in the fuse box under the hood on the right side of the vehicle. It should be fuse F2 - 400 amp. Check that fuse and let me know if it is blown.
Customer: replied 7 months ago.
Driver side or passenger side?
Expert:  Matt C. replied 7 months ago.
If this is a left-hand drive car it would be on the passenger side.
Customer: replied 7 months ago.
There is no 400amp fuse there
Customer: replied 7 months ago.
Only a 40amp ,7.5 amp ,a 25amp and 20 amp
Expert:  Matt C. replied 7 months ago.
I am sorry, I was just looking at the wrong thing. It should be either a 150 amp or 200 amp installed in slot 2 of that fuse box.
Expert:  Matt C. replied 7 months ago.
That didn't sent properly. Let me try this.
Customer: replied 7 months ago.
I dont see the slot 2
..no 200 amp fuse... does that top cover come off? I dont see where the fuse shoud be
Customer: replied 7 months ago.
Ive seen the diagram you sent but the fuse isnt on that box.. only 1 maxi fuse and 3 standard fuses
Expert:  Matt C. replied 7 months ago.
It should be located inside that box (where the wires bolt up to it).
Customer: replied 7 months ago.
So i have to remove all tge wires and go in the box?
Expert:  Matt C. replied 7 months ago.
I am trying to find a little more information on this, there is not much available, I am unsure if it is serviceable separately from the box as I have not personally had this issue on this model.I will opt out of this question to see if another expert has a little more information on this.
Customer: replied 7 months ago.
Ok ive looked everywhere online... the answer probably wont be online itd help if the tech knows firsthand flhow to replace the fuse.. thanks for ur help though
Expert:  Marty replied 7 months ago.
Hi. perhaps I can help. There is no fuse for the alternator on the S550 with the M273 engine. If you have no power to the large wire on the alternator the fault would be between the positive battery cable and the alternator. If you do have power to the large wire the problem will most likely be a defective alternator. You should get the car connected to the Mercedes Star Diagnosis tester to check for related fault codes.Let me know if you have any questions.Marty

Related Mercedes Questions