How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Mercedes
Satisfied Customers: 22107
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your Mercedes Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

E320: I have a 1999 e320 mercedes Benz; there's no power at

Customer Question

I have a 1999 e320 mercedes Benz; there's no power at the gas pedal. It does nothing. Changed throttle body and throttle sensor. I used it off a ml320 Mercedes Benz truck; are they the same?
Submitted: 11 months ago.
Category: Mercedes
Expert:  Lou P. master tech replied 11 months ago.
Hello, i am checking the parts catalog to verify if they are the same, what is the issue that led you to do this? what else have you tested,replaced, or tried? the more info the merrier.
Customer: replied 11 months ago.
No power when I step on the gas pedal
Customer: replied 11 months ago.
Yes
Customer: replied 11 months ago.
(Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Lou P. master tech replied 11 months ago.
depending on the serial number of the ML the sensor could not be compatible, there were 2 different sensors used, do you know how to use a multimeter to check voltage?
Expert:  Lou P. master tech replied 11 months ago.
ok i can accept the phone offer but i cannot call until tomorrow. if that is not a issue then let me know and i will accept. if it is a issue then i will opt out. as for tomorrow we can talk earlier the better, weekends are family time lol, i just seen a lot of posts needing assistance and i was trying to help out. so let me know how and if you wish to proceed .
Customer: replied 11 months ago.
I all so try one off a 2002 e320 still did not work
Customer: replied 11 months ago.
Sorry 2001
Expert:  Lou P. master tech replied 11 months ago.
the engine control module is what powers the sensor , so if you tried a few sensors its obviously not the sensor, have you checked for codes in the system?
Expert:  Lou P. master tech replied 11 months ago.
does the car rev at all when pressing the pedal?
Customer: replied 11 months ago.
Yes p1542
Customer: replied 11 months ago.
On the dash it say acc. Skid Asr Bas. Radiator
Expert:  Lou P. master tech replied 11 months ago.
ok, so you need to test the powers at the sensor, that will tell us what is happening, do you know how to use a meter? do you have a meter?
Customer: replied 11 months ago.
No just a little
Customer: replied 11 months ago.
No
Customer: replied 11 months ago.
Is the one off the 2001 e 320 the right one
Customer: replied 11 months ago.
I try to leave the key on for 5 min still did not work
Customer: replied 11 months ago.
Now what
Customer: replied 11 months ago.
Still waiting
Customer: replied 11 months ago.
You still there
Expert:  Lou P. master tech replied 11 months ago.
what are you talking about leave the key on for 5 minutes?
Customer: replied 11 months ago.
Am still waiting
Expert:  Lou P. master tech replied 11 months ago.
we are not on the same page, if you do not know how to use a multimeter than i will opt out, i cannot help you diagnose if you dont know how to use a meter. hopefully another expert can assist.
Customer: replied 11 months ago.
So am I being charged for this?
Expert:  sprinkles08 replied 11 months ago.
Hello and welcome to JustAnswer!The problem may be the sensor itself, wiring, it may be an issue with the throttle body or even in the engine controller itself.The first step in diagnosing the problem was to see what fault codes are setting and that will tell you were to begin testing. Do you know what fault codes are currently setting?
Customer: replied 11 months ago.
P1542
Expert:  sprinkles08 replied 11 months ago.
This code is for the accelerator pedal position sensor and could be the sensor, wiring or connections, or an internal issue in the engine controller. It's not likely to be an ECM issue and is almost surely being caused by the sensor or wiring. If the sensor was a known good or new factory part then you could be pretty certain there is a wiring issue. At this point you're either going to need a known good sensor or the proper electrical testing will need to be done to determine what is happening.
Customer: replied 11 months ago.
Are you going to call me
Expert:  sprinkles08 replied 11 months ago.
I'm not able to talk on the phone.
Customer: replied 11 months ago.
What is my next step to get it fix
Expert:  sprinkles08 replied 11 months ago.
At this point you're either going to need a known good sensor or the proper electrical testing will need to be done to determine what is happening.
Customer: replied 11 months ago.
How do you text it
Expert:  sprinkles08 replied 11 months ago.
A digital voltmeter will be necessary; you mentioned not having the equipment to do any testing.
Customer: replied 11 months ago.
What part am I testing
Expert:  sprinkles08 replied 11 months ago.
The accelerator pedal position wiring needs to be tested.
Customer: replied 11 months ago.
How much volts should be there
Expert:  sprinkles08 replied 11 months ago.
Test the voltage on each wire at the sensor with the sensor unplugged and key on, let me know what you find for each.
Customer: replied 11 months ago.
Ok thank you
Expert:  sprinkles08 replied 11 months ago.
You're welcome.
Customer: replied 11 months ago.
Pen 1 volts 4.97 pen 2 volts 3.94 pen3 o pen 4 0.23 pen 5 0 pen 6. O
Expert:  sprinkles08 replied 11 months ago.
Pin 1 should be black/brown, 6 is brown/yellow. Is that the order you read them in?
Customer: replied 11 months ago.
Pen 1 is blue and brown pen 6 is brown and yellow
Expert:  sprinkles08 replied 11 months ago.
What is the resistance to ground on pins 3 and 6?
Customer: replied 11 months ago.
Do you mean volts
Expert:  sprinkles08 replied 11 months ago.
No, resistance to ground. The meter will be set up to measure resistance.
Customer: replied 11 months ago.
Both are o
Expert:  sprinkles08 replied 11 months ago.
0 ohms, the same as if the leads were touched to each other?
Customer: replied 11 months ago.
My Freind just left so we need to put it on ohmsto get the reading
Expert:  sprinkles08 replied 11 months ago.
Ok.
Customer: replied 11 months ago.
So I need to put it on ohms to get the right reading
Expert:  sprinkles08 replied 11 months ago.
Correct.
Customer: replied 11 months ago.
Thank you I do that
Expert:  sprinkles08 replied 11 months ago.
Ok.