How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3721
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

I have a 2005 mercedes benz 500 sl that i purchased

Customer Question

Hello, I have a 2005 mercedes benz 500 sl that i purchased 6 months ago. In that time i haven't put 200 ***** ***** on as i own 3 other vehicles. I noticed from the beginning the convenience package says go to workshop, etc. Now, this morning I went to the bank and engine light comes on, a yellow triangle light with exclamation comes on and for the first time ever,..it won't shift out of first gear. Geez,..and, i am not mechanically inclined.
JA: Thanks. Can you give me any more details about your issue?
Customer: My name is Rick?
JA: OK got it. Last thing — Mercedes Mechanics generally expect a deposit of about $18 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 8 months ago.
Category: Mercedes
Expert:  Lou P. master tech replied 8 months ago.
Hello Rick, it sounds like the main battery may be dead or extremely weak, your model has 2 batteries, 1 for the starting of the car located in the engine bay and a 2nd battery in the trunk. i would suggest getting the batteries tested, also has it rained recently? was anything spilled on or near the shifter? it sounds like you also have communication issues that would result from water entry or a failed module. could also be related to the low voltage but we need to make sure the battery is ok first. Lou P.
Expert:  Lou P. master tech replied 7 months ago.
are you still needing assistance?

Related Mercedes Questions