How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, Mercedes Technician
Category: Mercedes
Satisfied Customers: 53166
Experience:  Bosch Certified Master Tech. Over 35 years experience.
13230946
Type Your Mercedes Question Here...
Marty is online now
A new question is answered every 9 seconds

It's a Mercedes CLS 350 w219 year 2006 m272 engine, we just

Customer Question

It’s a Mercedes CLS 350 w219 year 2006 m272 engine, we just finish rebuilt the engine. It was fine without any error when we start the engine and drive around below 2000RPM. But once it rave it above 3000RPM, it pop up error code 1200 and 1204, camshaft timing control exhaust bank 1 and 2 , specification not achieved (over retarded) –permanent.
We have try to swap or change the cam sensor and delete the code and do adaptation, the will pop up once above 3000 rpm, but below 3000rpm, it was fine.
Submitted: 8 months ago.
Category: Mercedes
Expert:  Marty replied 8 months ago.

Hi, my name is***** code is telling you that your exhaust cams are out of position. Either your camshaft timing is incorrect or you need to replace the exhaust camshaft adjusters (sprockets).

Customer: replied 8 months ago.
If my timing is incorrect, i will not be driving the car for more then 20 minute without any error code or check engine light. IF i keep the RPM below 3000RPM. It only appear only ABOVE 3000RPM.
There are two error code. 1200 and 1204.
Are you sure only exhaust camshaft adjusters ?
Expert:  Marty replied 8 months ago.

It's either the basic timing or the adjusters. If you have run the adaptions and you still get the code you need to replace the adjusters. I've done many of these for this problem. I'm assuming that you replaced the magnets when you rebuilt the engine. If you haven't tried new magnets you should do that first, otherwise replace the adjusters.

Customer: replied 8 months ago.
We have replace the new 4 solenoid cam control and cam shaft position sensor rotate intake and exhaust , replace the balancing shaft too
Expert:  Marty replied 8 months ago.

Ok, then i would go ahead and replace the exhaust camshaft adjusters.

Customer: replied 8 months ago.
the exhaust camshaft adjusters has been replace too. both NEW intake and exhaust.
Customer: replied 8 months ago.
I am worry if my guy mixes up the exhaust and intake cam. Will there be a problem if we accidently misplace them or the rocket arm. The engine will not crank up if that mistake happens.
Expert:  Marty replied 8 months ago.

If the cams were swapped it wouldn't run. I've got to believe your timing is not correct or you have to readapt the cams. I've had some where I had to repeat the adaption process over and over until it took.

Customer: replied 8 months ago.
I am worry if my guy mixes up the exhaust and intake cam. Will there be a problem if we accidently misplace them or the rocket arm. The engine will not crank up if that mistake happens.
The timing mark for M272 is strait forward as picture show. So I believed I have only 2 option
1. Readapt the cam – will try for 5 time
2. Open the cam cover and show you the cam timing mark with the crankshaft pulley timing marks.
I have Picoscope, do you think I should give it a try; I have not used it before and I am not sure where to start with my picoscope 4423.
Customer: replied 8 months ago.
Sorry for the repeat question. accidentally copy all.
Expert:  Marty replied 8 months ago.

You can also inspect the cam timing through the cam sensor holes. Have you replaced the plates at the front of the cams? If the nub on the plate shears it can allow the plate to rotate when you tighten the cam sprocket. I don't think the scope will tell you anything that you don't already know, the exhaust cams are out of time.

Customer: replied 8 months ago.
I think my this engine it's a little different which it does not has the cam hole which you referring. Its 10pm now so I had wait till tomorrow to know the result. The are few adaptation option. Which adaption are we referring? I am using Delphi. My star laptop is currently corrupted. Do I really need it.
Customer: replied 8 months ago.
Just try using my DAS/Xentry year 2010 version, what i did is
First = Resetting of adaption data, complete
Second = Tech-in Process after engine replacement BUT it fail when it requesting me to start the engine, it’s just suddenly response as process time out. May be its because the temperature went above 80c after i start the engine. Will try again early in the morning.
Customer: replied 8 months ago.
I was using Delphi yesterday , ONLY today i try using my DAS as you notice my das is an 2010 version.
Customer: replied 8 months ago.
Additional = YES we have replace 4 pieces of the plates at the front of the cams