How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 4085
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

2004 MB CL 500, ABS light frequently on Red and the car tilt

Customer Question

2004 MB CL 500, ABS light frequently on Red and the car tilt to the left (front & back) however it got left up by pressing the vehicle level control switch, what could be the problem, note the switch solution does not always work and need to wait for few hours to have it work.
Submitted: 1 year ago.
Category: Mercedes
Expert:  Lou P. master tech replied 1 year ago.

Hello, does the car sag on one side after it sits for a few hours?

Customer: replied 1 year ago.
one side and always the left (front & back)
Expert:  Lou P. master tech replied 1 year ago.

OK,. so what needs to be monitored is if its the front or rear because they are on separate circuits hydraulically so if the front is leaking it will pull down the whole side so its important to measure when car is shut off and then again after 4 hours. can you do this?

Customer: replied 1 year ago.
Please check the attached fault reports and advise if it helps to diagnose the ABS problem
Expert:  Lou P. master tech replied 1 year ago.

WILL DO give me a little time

Customer: replied 1 year ago.
1: Still can't find out whether front or rear !
2: you did not come back to me on the fault reports.
Expert:  Lou P. master tech replied 1 year ago.

Sorry my last message must not have gone through ! Your codes tell nothing of the ABC suspension. It appears your scan tool does not read the ABC module. All the codes you have are from engine and body and transmission. You will need a better scan tool to read the ABC control module. Then I can help a little better BUT you need to measure the car when first shut off and re measure after a few hours that will tell me what is failing. Most likely it is a valve block. The car had 2. One for the front struts and one for the rear struts. They both go bad but not usually at the same time. But it could happen. Also sometimes instead of replacing the starts we use the scanner to activate the shut off valves to maybe clear them out and then flush the fluid and that has helped at times. Hope this information helps.

Expert:  Lou P. master tech replied 12 months ago.

are you still needing assistance?