How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask rpmdiag Your Own Question
rpmdiag, Tech and Instructor
Category: Mercedes
Satisfied Customers: 6724
Experience:  Since 1975
Type Your Mercedes Question Here...
rpmdiag is online now
A new question is answered every 9 seconds

I have a 99 c230 compressor with no acceleration pedal

Customer Question

I have a 99 c230 compressor with no acceleration pedal response. I have changed out the TPS and the Throttle body. This car does not have a pedal sensor on the gas pedal. Is my ECU bad. The battery has also been removed from the car during all of this. My original problem was the K40 fuse module. I swapped it out. I have also had another one.
Submitted: 7 months ago.
Category: Mercedes
Expert:  rpmdiag replied 7 months ago.

Hi, I’m Ron and I can help you.
I have been in this business since 1975 and also teach automotive repair. I am confident
we can resolve your problem together. Please understand that I don't know your skill
level. I can't see, smell, hear, or touch the vehicle either, so it may take a few replies to
get to satisfactory results. Please be patient!
I also try to give all of the information you may need, expecting a “positive rating” in
return. I will also continue assisting you after you have rated me, if necessary. If there
is any reason I cannot get a positive rating, please let me know why “in advance”, so I
can go another direction for you. I am sorry you’re having this problem; I’ll help you
through it.

The computer needs to be thoroughly scanned for pertinent data related to throttle response. A lab scope may also be needed to see what the TP is actually doing.

Thanks, Ron

Related Mercedes Questions