How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, Mercedes Technician
Category: Mercedes
Satisfied Customers: 53168
Experience:  Bosch Certified Master Tech. Over 35 years experience.
13230946
Type Your Mercedes Question Here...
Marty is online now
A new question is answered every 9 seconds

I have a 2002 AUDI A6 i dont have any power at my fuel pump

Customer Question

Hi my name is ***** ***** have a 2002 AUDI A6 i dont have any power at my fuel pump fuse
Submitted: 9 months ago.
Category: Mercedes
Expert:  Marty replied 9 months ago.

Hi Willie, are you checking fuse 28 for voltage when cranking the motor? If you have no voltage I'd try a new fuel pump relay.

Expert:  Marty replied 9 months ago.

The relay is located on the relay panel under the left side of the dash.

Expert:  Marty replied 9 months ago.

Click on the attachment below.

Customer: replied 9 months ago.
we replaced fuel pump relay.
Expert:  Marty replied 9 months ago.

Have you checked your inputs to the relay? You should have power on pin 17 and 19 with the key on.

Customer: replied 9 months ago.
it is power on 17 & 19 with the key on
Expert:  Marty replied 9 months ago.

Will the car run if you bypass the fuel pump relay?

Customer: replied 9 months ago.
how to bypass the relay.
Expert:  Marty replied 9 months ago.

You will need to remove the relay and place a fused jumper lead from terminal 17 (power in) to terminal 20 and 23 (power out).

Customer: replied 9 months ago.
HI MARTY it wont run with the jumper
Expert:  Marty replied 9 months ago.

Ok, so it sounds like you have more than a fuel pump problem. The ECU energizes the fuel pump relay and initiates spark and fuel injection. Have you tested for spark and injector pulse? Will it run if you spray ether into the air intake?

Customer: replied 9 months ago.
I haven't checked injector pulse, but I dont have spark. And the check engine light doesnt come on when you turn the switch on.
Expert:  Marty replied 9 months ago.

Sounds like there is no power to the ECU or the ECU is bad. I'd start by checking for power at the ECU.

Customer: replied 9 months ago.
Is this where you check pins # ***** 55, 56, and 62 for voltage. If so they all have voltage & pins 1 & 2 has ground.
Expert:  Marty replied 9 months ago.

I'm not sure if those are the correct pins but if you have power and ground to the ECU and no spark, fuel pump or injector pulse you may have a bad ECU. Have you checked the timing belt to see if it broke? Checked compression?

Customer: replied 9 months ago.
HI MARTY that is all good the car started at the begaining to run rough and then started to skip and then it would not even crank one TEC. said it could be the switch no one has been able to help.
Customer: replied 9 months ago.
Good Morning Marty i was just wondering if you were still with me, Last I had said the timing belt and compression are OK it had started to skip and it got where it would not run. IF you dont have the time to help i understand, but could you refer me to another TEC that could help me THANKS,
Expert:  Marty replied 9 months ago.

Hi Willie, I'm out of the office until Monday. I will opt out for now and check back with you on Monday.

Customer: replied 9 months ago.
HI Marty i was wondering if you got anything else on the AUDI
Customer: replied 8 months ago.
Marty did you find anyone to help me i am still here.