How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 4057
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

Marty, I have a 2003 Mercedes S500 (w220), the following

Customer Question

Hello Marty,
I have a 2003 Mercedes S500 (w220), the following items do not work when I start the vehicle: wipers, a/c, headlights, turn signal, trunk opener, power windows.
Submitted: 11 months ago.
Category: Mercedes
Expert:  rpmdiag replied 11 months ago.

Hi, I’m Ron and I can help you.
I have been in this business since 1975 and also teach automotive repair. I am confident
we can resolve your problem together. Please understand that I don't know your skill
level. I can't see, smell, hear, or touch the vehicle either, so it may take a few replies to
get to satisfactory results. Please be patient!
I also try to give all of the information you may need, expecting a “positive rating” in
return. I will also continue assisting you after you have rated me, if necessary. If there
is any reason I cannot get a positive rating, please let me know why “in advance”, so I
can go another direction for you. I am sorry you’re having this problem; I’ll help you
through it.

It's possible that you have a bad ground somewhere that is common to all those problems. Start with checking you battery cable ground first for tightness or corrosion.

Thanks,Ron

Customer: replied 11 months ago.
Hello Ron, I already checked the battery cables, I also replaced the battery.
Customer: replied 11 months ago.
I also replaced all modules, generator, radio and ignition.
Expert:  rpmdiag replied 11 months ago.

You may have needed to program one or all of those modules to. I'm not at my database today to know for sure.

Thanks again, and please don't forget to rate me and keep this link in case you need me again later on. You should also check the computer grounds as well.

Ron

Customer: replied 11 months ago.
The modules are from the same model car, same part numbers...etc. The modules are operating as intended, however the symptoms are still there.
Also the symptoms are not present when ignition is 2nd position, the symptoms come on only when the vehicle is started.
Expert:  rpmdiag replied 11 months ago.

Okay, then I would attach a scan tool and do bidirectional testing of the complete system to find where this error is coming from. This testing should reveal our problem.

Ron

Expert:  Lou P. master tech replied 11 months ago.

Alec I am a Mercedes technician. First I need you to start the car and test every fuse in the driver side and passenger side engine bay fuse box also the fuse box on the passenger side of the dash and also the fuse box under the backseat test every fuse for power we are not only checking for a blown fuse but also for power to all the fuses let me know which fuses do not have power and I will compare that with a diagram, Lou P

Customer: replied 11 months ago.
Lou, i did that, i went further and replaced all those fuse boxes/modules both under the hood and the one under rear seat.
Expert:  Lou P. master tech replied 11 months ago.

OK well you may have caught yourself more problems because the new modules have to be coded to the car

Expert:  Lou P. master tech replied 11 months ago.

OK the issue you were having is an interior Can issue. Do you own a Mercedes scan tool ?

Expert:  Lou P. master tech replied 11 months ago.

Do you know what the "can data bus " is?

Expert:  Lou P. master tech replied 11 months ago.

I also asked to check the fuses for power because there are certain relays that are active at certain key positions. I was not simply looking for a blown fuse.

Customer: replied 11 months ago.
Gentlemen, lets schedule a time to resolve this issue on monday.
Expert:  Lou P. master tech replied 11 months ago.

I will be here when you need me. I will receive emails so no worries I will always respond back to you

Expert:  Lou P. master tech replied 11 months ago.

Alek are you still needing assistance?