How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Engineer
Category: Mercedes
Satisfied Customers: 20597
Experience:  Mechanical Engineer with 23 years experience in the auto industry, 8 yrs in formula 1 engine testing
12772297
Type Your Mercedes Question Here...
Matt is online now
A new question is answered every 9 seconds

I have a 2003 cdi 316 sprinter which is very hard to start

Customer Question

I have a 2003 cdi 316 sprinter which is very hard to start in the mornings or cold but starts ok when warm ( sometimes ) but once I reach 100kph the edc light comes on n I lose cruise control .. the fuel filter has just been replaced by mercedes and where is the edc located in the van .. any help very much appreciated .. Thanks Mike
Submitted: 9 months ago.
Category: Mercedes
Expert:  Matt replied 9 months ago.

Hello

I'd check that you're getting full power to the glow-plugs, they pull a lot of current so take care when checking but see if the relay is clicking when the ignition is turned on first and also check the fuse if this is OK check to see if the engine earth strap is also OK.

If the plugs haven't been changed in the last 20K then they may have to be replaced.

You can test the glow-plugs with a multimeter by measuring the resistance across the plug ( between the power connection and the body) it should be around 4-8ohms if its tending to infinity / open circuit the plug is faulty or by using a clip on current clamp, either on the supply wire to glow plugs or onto engine earth, with glow plug light on you should see 15-20amps for each glow plug fitted, 4 cylinders would be approximately 60-80amps.

Also if its not injecting at all then check the connections to the crankshaft sensor, unplug it and check for corroded contacts and broken wiring, and consider fitting a new sensor - do the same for the cam position sensor

If the EGR valve is stuck open then this too can effect starting so try disconnecting it to see if this helps or changes anything

Could also be an injector leaking fuel back through the overspill pipe, so not getting enough fuel pressure to tell ECU to fire the injectors, this is trickier to find and you’ll need the garage to do a ‘run back’ test to identify which one is the issue

Related Mercedes Questions