How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask MB Paul Your Own Question
MB Paul
MB Paul, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3567
Experience:  Qualified Mercedes Benz Diagnostic Technician - 20+ years experience - Workshop Foreman for Mercedes
15777119
Type Your Mercedes Question Here...
MB Paul is online now
A new question is answered every 9 seconds

Morning. I believe I have a vacuum leak and its causing the

Customer Question

Customer: Morning. I believe I have a vacuum leak and its causing the car to sputter when its cold out, in fact, the colder it is, the more it does it. RPM jump and down, then it idles normal for a bit, as the engine temp starts to rise, the idle jumps up and down again then nulls out, after it warms up to 60 C it does it again then nulls itself out. Now its doing it even when driving at 65 mph, only when its really cold out.
JA: Thanks. Can you give me any more details about your issue?
Customer: Very rough idle on cold morning. the warmer the temp is outside the less rough idle there is, the colder it is outside the worse the rough idle is. On really cold days like today, when driving at highway speed the lights dim and brighten, the radio cuts off then back on but the RPM stays consistent because my foots on the gas.
JA: OK got it. Last thing — JustAnswer charges a fee (generally around $18) to post your type of question to Mercedes Experts (you only pay if satisfied). There are a couple customers ahead of you. We can help you for less if you're not in a rush. Are you willing to wait a bit?
Customer: yea sure. I think I have this figured out already but some sound advice wont hurt
JA: OK. Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 10 months ago.
Category: Mercedes
Expert:  Lou P. master tech replied 10 months ago.

Hello, can you tell me if there is a check engine light on? also have you checked the charging voltage when running?

Customer: replied 10 months ago.
Hey good morning. the CEL came on yesterday finally on the way home. In the past, when the engine would reach operating temp the problem would go away and the car ran like a champ. Ill be able to check and see what the codes are tonight when I get home. No i dont have a meter to test what the battery charging voltage is. To date there is no problem with starting the car in the morning, no delay, nothing that sounds like the battery is low.
Expert:  Lou P. master tech replied 10 months ago.

OK, thanks for the info, tells me that when the system goes into closed loop it starts to run better , so you may have a sensor issue instead of a mechanical issue. let me know the codes and I can assist for sure. Lou.

Customer: replied 10 months ago.
Will do Lou, thanks. Am I able to pick this conversation up tonight after I get home and check the codes?
Expert:  Lou P. master tech replied 10 months ago.

absolutely man, I get emails when you respond, so give me time to get back with you, ill stick with you until we come to a conclusion. :)