How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Mercedes Mechanic
Category: Mercedes
Satisfied Customers: 24727
Experience:  Over 15 years experience as a Mercedes dealer technician
14928985
Type Your Mercedes Question Here...
Pete is online now
A new question is answered every 9 seconds

My name is ***** ***** Shaw, I've been experiencing some

Customer Question

Customer: hey my name is ***** ***** Shaw, I've been experiencing some problems with my 2005 e320. Basically as I was driving home in some heavy rain and got a drop of water on my shoulder I looked up to notice my sun visor had gone up(I know it was down) when I tried to pull it down it didn't work my over head control panel seems to have lost power. when I open the doors at night the lights do not come on at all and I cannot manually click on the front overhead lights but I can the back ones. About 4 days goes by and then my radio went out like the nav/radio screen will turn on and say Mercedes benz with the logo but will shut off after a moment. After reading about fuses in the trunk I decided to check the trunk and around the battery, there was water around the battery in the right corner not much a very small puddle but the wires on the right side were wet. I quickly dried it. Few sunny days goes by and I went out to start my car in the morning and got a message saying " low battery convey. some functions may be temporarily unavailable " (trunk was dry no rain for few days) so I got a friend to come give me a jump and my car started right up my radio and nav screen came back on allowing me to listen to the radio again but my over head control panel still has no power ( cant use sunroof/visor or turn on overhead lights) ive read that's possibly the f9 fuse in the trunk but my ground lighting is still out too like when I open the doors at night also when driving at night the rear dome no longer illuminates either but I can click on the lights manually. after a week the radio went out again I went to autozone and got my battery alternator and started checked and he said they were all fine. Furthermore this morning I went out to my car and I thought my car keys battery was dead because I could not unlock my car so I went and got a new battery for the keys, no results and noticed a read light blink when I clicked lock or unlock so I manually opened the trunk and got a jump. after a minute or so I tried to start it and could not after 20 minutes of leaving the car jumper cables hooked up it finally started and my radio came back on
JA: Thanks. Can you give me any more details about your issue?
Customer: I need to fix my ocp so that my sunroof works and need to know if the water completely fried sll those wires or is the battery drain
JA: OK got it. Last thing — JustAnswer charges a fee (generally around $18) to post your type of question to Mercedes Experts (you only pay if satisfied). There are a couple customers ahead of you. Are you willing to wait a bit?
Customer: how long would that wait be
JA: OK. Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 10 months ago.
Category: Mercedes
Customer: replied 10 months ago.
Sorry the end is confusing. I need to know if the wires are fried and unrepairable by me (possibly costing thousands for replacement by dealer which I cannot afford right now) or can I hopefully replace a fuse or relay to get the ocp working again and the battery drain possible be elsewhere which I read is common in early w211s i.e SOS tele-aid malfunction attempting to make phone calls draining the battery overnight which my display DOES read on dash SOS tele-aid malfunction drive to workshop. It has been on the display since I bought the car a year ago it was the only message on the dash. I do not has a car history on the report but has not given me problems the whole year ive had it other than this now. It is my daily driver the car had 104k miles when I bought it. It now has 130k exactly
Expert:  Pete replied 10 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

The first thing that needs done here is to have the fault codes checked to see if any codes are set.This needs done with a scan tool or computer plugged into your vehicle that can communicate with all computers.Once this is done any codes set will need diagnosed to locate and repair this fault here.I would have the wiring checked as well to see if any wiring faults are found needing repaired or replaced.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete