How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Stan Your Own Question
Stan
Stan, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3526
Experience:  Technical support engineer
16766657
Type Your Mercedes Question Here...
Stan is online now
A new question is answered every 9 seconds

I have a 2004 Mercedes SL 600. Had rear auxiliary battery

Customer Question

I have a 2004 Mercedes SL 600. Had rear auxiliary battery replaced at a local shop and they replaced it with a lead acid battery. The check battery light came on. Tried recharging it and it said bad cell. Took it back and they replaced it with a agm battery. Check battery light has been on sense. How do I fix it. Also had H IDs installed in the foglamps, started throwing a code for foglamps replaced it with the regular bulbs and now they don't want to turn on. Wanted to check the fuse but it says electronic fuse. Is there a way to replace an electronic fuse but I've messed something else up. One of my shocks was leaking so had one shock replaced and now it's saying check ABC suspension could it be just an abc flush and filter.
Submitted: 10 months ago.
Category: Mercedes
Expert:  Stan replied 10 months ago.

Hello,
First of all please make sure that also the starter battery under the hood is properly charged. Battery control module controls the charge state of both batteries.

If both batteries are ok, but problem persists- disconnect the trunk battery for several hours. THis should reset the battery control module and the fog lights electronic fuse.
If the ABC has not been bled out after replacing the strut with Star Diagnosis computer- this must be done first. Flush and filter change is also a good idea.

Connecting Star Diagnosis and reading out all of the fault codes will clarify what is causing the battery and fog light issue, if battery disconnect will not help.

Best Regards,
Stan

Customer: replied 10 months ago.
I did make sure the front battery was charged and did charge and unplug the rear overnight. The battery and fog lamp lights are still on
Expert:  Stan replied 10 months ago.

If this did not help, this is all what can be done without Star Diagnosis computer. Electronic fuses are built into fron SAM module. Next steps are to delete the fault codes, and update the battery control module software. The fog lights can be switched on for testing with the Star Diagnosis as well to make sure that electronics and wiring are in order. One thing to keep in mind with the bulbs- they mist have the same rating as the original bulbs.