How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Mercedes
Satisfied Customers: 33467
Experience:  ASE Certs.
7276279
Type Your Mercedes Question Here...
Ron is online now
A new question is answered every 9 seconds

I have a 2008 Mercedes CL K350 convertible. I just recently

Customer Question

Hi, I have a 2008 Mercedes CL K350 convertible. I just recently had the front windshield replaced. I also gave a car a jump recently– (included just in case electrical might be involved).
Problem - I recently tried to put the top-down and it worked up until the top needed to lift off the front windshield but then nothing happened. I can close it up again but when I try to put it down it always stops at that same position.
Submitted: 11 months ago.
Category: Mercedes
Expert:  Ron replied 11 months ago.

Hello, my name is ***** ***** I am a professional here at Just Answer. I have noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

The problem you are describing can be caused by any of the following,

  • Convertible Top Hydraulic Pump
  • Convertible Top Position Switch
  • Convertible Top Storage Lid Latch
  • Fuse
  • Roll Bar Assembly

    In order to determine what has failed you are going to need to do some testing, See the steps in the link below. Copy and paste the link toy our browser to open and view it.

    https://dl.dropboxusercontent.com/u/104923897/Con%20Top%20Jan%204.pdf
Customer: replied 11 months ago.
Hi Ron, thank you for your reply. I have already done all the things that I could find online and the manual. Everything's seems to be working just fine except when the top needs to lift off the front windshield. It stops but the motor keeps running. The company that replaced the windshield is coming out to take a look. They seem to think it has something to do with the installation of the windshield. Maybe a sensor?
Expert:  Ron replied 11 months ago.

Okay that a good place to start. Let me know the results and we can work from there.