How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Mercedes Mechanic
Category: Mercedes
Satisfied Customers: 24721
Experience:  Over 15 years experience as a Mercedes dealer technician
14928985
Type Your Mercedes Question Here...
Pete is online now
A new question is answered every 9 seconds

Back shocks droped there is no leaks the levler arm is not

Customer Question

back shocks droped there is no leaks the levler arm is not brock
Submitted: 12 months ago.
Category: Mercedes
Expert:  Pete replied 12 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

Even though the level arm is not broke the level sensor may be at fault internally sending an incorrect signal on what level the suspension or height of the vehicle is and can be causing this fault here.I have seen this several times before and had to replace the level sensor for this fault here.The signal from the level sensor will need tested to see if this is the cause here.The fault codes also need checked to see what codes are set in the vehicle and those codes diagnosed to help locate and repair the cause of the fault here.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 11 months ago.
That's not the problem put new sensor still not working
Expert:  Pete replied 11 months ago.

Have you had fault codes checked at all using a scan tool that can communicate with all computers in your vehicle?

Related Mercedes Questions