How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Mercedes
Satisfied Customers: 21589
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your Mercedes Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

05 s500 Think there is a problem either with smart key or

Customer Question

05 s500
Think there is a problem either with smart key or the computer recognizing it.
When stopping the engine (without inserting the smark key directly into the ignition switch, using the start/ stop button on shifter) The message display starts flashing back and forth between "key not recognized" and " key still in vehicle".. and it looks sporadic or flashy almost like a short if that makes sense.. after leaving the vehicle, and closing the door the cluster lights remain on, and every few secs the radio display shows the mb logo, then goes off again. the red light is flashing on the fob.. I tried replacing battery it made no difference.
If I lock the vehicle using the FOB, several seconds later it's as if I continue to press the lock button and it continuosly does this. the flashers blink and the dash stays illuminated.
The only way I found to get the cluster lights to go out is to manually insert the fob into the ignition and start and stop the vehicle, and then wait for the cluster lights to go out, but you have to leave the key in the ignition. If you remove it the cluster comes back on and stays lit.
Any thoughts??
Submitted: 12 months ago.
Category: Mercedes
Expert:  sprinkles08 replied 11 months ago.

Hello and welcome to JustAnswer!

You may have quite a few things going on such as a failure in the electronic ignition switch but the issue may be the fob itself. Have you tried a second fob to see if the symptoms are present and the same?

Customer: replied 11 months ago.
Only have one fob, and another issue arose yesterday.. even with using the key in the ignition the power is staying on to the radio.. with the ignition switch in the off position and the drivers door open the radio will stay on u less powered off manually.. additionally i noticed the steering wheel is not locking when ignition is off with key removed
...
Expert:  sprinkles08 replied 11 months ago.

Do the turn signals, blower motor or anything else still work with the key off?

Customer: replied 11 months ago.
As far as I can tell the radio is the only thing that is "hot" I was thinking maybe the door switch had something to do with it, but the interior lights go out when door is closed
Expert:  sprinkles08 replied 11 months ago.

Do you have access to a full capability scan tool?

Customer: replied 11 months ago.
snap on should work right? As far as I can tell there are no codes though
Expert:  sprinkles08 replied 11 months ago.

You have the capability to communicate with all modules?

Customer: replied 11 months ago.
I think so. It's a friends..I'll find out in morning. .
Expert:  sprinkles08 replied 11 months ago.

Ok.

Customer: replied 11 months ago.
This is my elderly parents car. . I went to pick it up this morning to go get scanned and it's completely dead. . No power to anything
Expert:  sprinkles08 replied 11 months ago.

Do the headlamps work?

Customer: replied 11 months ago.
No... everything was dead..... so I got to thinking that as far as I could remember the original battery from 05 was in the vehicle and we had never had a problem.. but nonetheless I knew it needed a new one if that was the case. Got battery and replaced. Everything was fixed BUT the radio.. it is still hot. I tried every scenario with the key and it stays hot.. I even sat in the car, had someone take the fob lock the car and walk away.. Cluster lights went out, the backlit power button on the radio stays illuminated and if pushed the radio will come on and play. The steering wheel still doesn't lock either, but that may be another issue all together and really isn't that big of a deal.. After hearing this my mother tells me that "now that you mentiioned it, for the longest time while driving the radio would just turn itself off, or vice versa, it would just come on. So now I'm thinking that it was caused it all.. The radio issue finally drained a very old battery causing all the issues with the cluster lights and fob. Which as I said seems to be corrected.. But the radio is still hot. which is going to make same thing happen to this battery if I can't fix.. Any thoughts... Thanks for all your help.. it's greatly appreciated...
Expert:  sprinkles08 replied 11 months ago.

The radio will need to be replaced if it's the only thing staying awake with the key off.

Customer: replied 11 months ago.
ok... can you tell me where the fuse is so I can dis able it? Owners manual says there is a fuse chart on 380... but there is no mention of a fuse on that page.. and there is no fuse chart anywhere in the manual that I can find... from looking on the net I saw that f24 is the audio system and f22 the nav.. and supposedly they are in the engine compartment left side fuse box.. But without a chart, I have no way to know which ones they are... if they are even the correct numbers
Expert:  sprinkles08 replied 11 months ago.

I will get back to you as quickly as I can.

Expert:  sprinkles08 replied 11 months ago.

Do you have the VIN?

Related Mercedes Questions