How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Michael Warfield Your Own Question
Michael Warfield
Michael Warfield, Factory Mercedes-Benz Technician
Category: Mercedes
Satisfied Customers: 3131
Experience:  Mercedes-Benz Master Certified technician
37243545
Type Your Mercedes Question Here...
Michael Warfield is online now
A new question is answered every 9 seconds

My car display is going. Break lights stay on and when I

Customer Question

My car display is going nuts. Break lights stay on and when I turn lights on a fan kicks on and usually the display lights go off
Submitted: 1 year ago.
Category: Mercedes
Expert:  Michael Warfield replied 1 year ago.

It definitely sounds like one of the sam/fuse box modules went bad. There are two of them, a front and a rear one. They are typically sensitive to voltage changes from jumpstarts etc...especially the rear one. Did you have the vehicle jumpstarted?

Customer: replied 1 year ago.
changed the battery
Expert:  Michael Warfield replied 1 year ago.

The brake lights are stuck on in the rear, correct?

Expert:  Michael Warfield replied 1 year ago.

Do the front headlights and turn signals all work or do only the front turn signals work and not the back?

Customer: replied 1 year ago.
Also when I turn the light on a fan comes on and the display goes black te the radio goes off a the break light sign comes on and so fourth
Expert:  Michael Warfield replied 1 year ago.

Do all of the turn signals work or only the front or rear?

Customer: replied 1 year ago.
The signals go nuts and won't work if I turn my lights on
Expert:  Michael Warfield replied 1 year ago.

But the headlights do turn on?

Customer: replied 1 year ago.
Expert:  Michael Warfield replied 1 year ago.

It definitely sounds like the rear sam computer was damaged due to the voltage fluctuation. Have you tried disconnecting the battery for about 10 minutes to see if that resets it?

Customer: replied 1 year ago.
Not today since I put the alt on. It was saying the battery was low so I have had it on the charger.
Expert:  Michael Warfield replied 1 year ago.

If that doesn't work, then I'm afraid you'll have to replace the rear sam. A new one is a little expensive but I found one here http://www.ebay.com/itm/MERCEDES-C240-REAR-SAM-BCM-SIGNAL-ACQUISITION-MODULE-FUSEBOX-203-545-07-01-/221926416375?fits=Year%3A2001%7CModel%3AC240&hash=item33abd85ff7:g:41QAAOSwl9BWGCjd&vxp=mtr

Expert:  Michael Warfield replied 1 year ago.

To replace it, just expose the rear fuse box in the trunk. The rear sam assembly is the whole fuse box. Just peel back the panel on the left side of the trunk and replace this fuse box with sam assembly making sure all the fuses and relays are in the same location as the one you are taking out.

Expert:  Michael Warfield replied 1 year ago.

You shouldn't need to program it since it is coming out of another C240.

Customer: replied 1 year ago.
Ok I'll try to undo the battery and see if that works. If not I'll order that part. How do I get ahold of u again if needs be
Expert:  Michael Warfield replied 1 year ago.

If you just click my profile, you should be able to request me directly.

Expert:  Michael Warfield replied 1 year ago.

If you have any questions, please don't hesitate to ask. Also, don't forget to rate our chat, thanks!

Customer: replied 1 year ago.
Ok great I will
Expert:  Michael Warfield replied 1 year ago.

Let me know if the reset worked and/or if you have success with the rear sam after you install it.