How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask MB Paul Your Own Question
MB Paul
MB Paul, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3567
Experience:  Qualified Mercedes Benz Diagnostic Technician - 20+ years experience - Workshop Foreman for Mercedes
15777119
Type Your Mercedes Question Here...
MB Paul is online now
A new question is answered every 9 seconds

My 320 sl wont crank. I drove it to Church and came out and

Customer Question

my 320 sl wont crank . I drove it to Church and came out and turned the key,. It turned slightly and that was it. Had it towed. a mobile mechanic replaced the starter, but it still wont crank. A week prior I had replaced the battery. could it be the alarm system/ some of the inside compartments are locked and I can't get them to open.
Submitted: 1 year ago.
Category: Mercedes
Expert:  AZTechBrian replied 1 year ago.

Hello. This might seem like an obvious question, but was the battery checked to see if it has a full charge and if both the battery cables are tight?

Customer: replied 1 year ago.
the battery is brand new. only replaced a week prior. I put it in myself. It try's now and then to turn over. bur just a mere turn, then it goes back to just a light sounding click from under the hood. I only used the car when I come to town. It may set idle for a couple of months. I usually unhook the battery post. The other problem I notice that my center console locked up. which occurred when this happened. Could the alarm system have something to do with the problem, or a faulty starter relay(what my brothers an electrician thinks may be the problem)?
Expert:  AZTechBrian replied 1 year ago.

If you turn the key, and the engine cranks a little, then stops cranking and starts clicking, that is very consistent with a low battery. Possibly something has come on while it was sitting that drained the battery.. Have you tried to jump start it so we can be absolutely certain that the battery has a full charge and is not the problem here?

Customer: replied 1 year ago.
Brand New battery> a battery technician already check it out. gave me the print out. he stated that the battery works perfectly. When it does try to turn it turns with vigor of a fully charged battery.(battery has been ruled out).
Expert:  AZTechBrian replied 1 year ago.

Ok. And battery and cable connections have been ruled out as well? If it begins to crank then stops, then your immobilizer, or anti theft system is not the problem. It's either a lack of power at the starter, or something causing excessive drag on the engine like a seized accessory. Have somebody try removing the belt and crank it then to rule out a bad accessory. Please come back and let me know how that goes.

Customer: replied 1 year ago.
Well it has never begin to crank, sorry, if I miss lead you. I meant to say, that it begins to turn over occasionally after =/- 10 attempts with the key and then back to no sound, or ever so audibly, a tick sound when e key is turned. We tried the belts, all working ok. It must be something else. By the way, all of the compartments have lock me out for some unknown weird reason?
Expert:  AZTechBrian replied 1 year ago.

Can you try to turn the key to the crank position, and jiggle the key in the ignition cylinder and see if it does anything? If all the cables and connections are definitely tight, then I am thinking possibly an issue with the ignition switch.

Customer: replied 1 year ago.
That didn't work... Thanks, ***** ***** . I'm having it towed to the repair shop up he street... Thanks for your help.
Expert:  AZTechBrian replied 1 year ago.

Ok. Please let me know what they determine if you don't mind.

Customer: replied 1 year ago.
Thanks I will do. I will take next week, or when they let me know have space available
Expert:  AZTechBrian replied 1 year ago.

Ok. In the mean time please check the battery connections again and make sure they are good. disconnect it, clean it up, re connect it. It seems very odd that this was an issue after a simple battery replacement and this could definitely be caused by a bad connection. I see it all the time. I just don't want to see you spend a bunch of money at a shop and on a tow if the issue is that simple. Sorry if I sound like a broken record.

Customer: replied 1 year ago.
Thanks Again, I will try it.
Expert:  AZTechBrian replied 1 year ago.

Ok. Please let me know the outcome either way. Thanks