How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, Mercedes Technician
Category: Mercedes
Satisfied Customers: 53160
Experience:  Bosch Certified Master Tech. Over 35 years experience.
13230946
Type Your Mercedes Question Here...
Marty is online now
A new question is answered every 9 seconds

Marty My car has been standing 4 months I took car to a

Customer Question

Hi Marty
My car has been standing for about 4 months I took car to a valet ers inside and out but not the engine compartment When I went to pick it up they had the heaters full on with the car running to dry it out. They used far too much water on the carpets. Long story short the car would not come out of park so I turned engine off but then the engine would not start just a small click. My mechanic came round tried a boost machine and said its not the battery. After 3 days stuck at the valletters my mechanic managed to get my car going and got it home. I found out that it was the battery that cause the car not to start after charging the battery the car started first time. The big problem I have now is the car only stays in first gear and does not shift up.
Sorry this is a bit long winded but I tried to give you as much info as poss. The car is a Mercedes 320 clk year 2000
Hope you can help
Regards
Paul
Submitted: 1 year ago.
Category: Mercedes
Expert:  Marty replied 1 year ago.

Hi Paul, it sounds like they soaked the electronic selector module and damaged it. The module is the complete gearshift assembly.

Expert:  Marty replied 1 year ago.

You will need to get the car to a Mercedes specialist to read out the fault codes in the transmission control module. More than likely there will be communication faults stored with the selector module.

Expert:  Marty replied 1 year ago.

Sometimes erasing the fault codes will fix it but if it doesn't work they will need to replace the shifter. Another possibility would be a bad speed sensor in the transmission but that would have nothing to do with the detail. The fault codes will point to the problem.