How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Michael Warfield Your Own Question
Michael Warfield
Michael Warfield, Factory Mercedes-Benz Technician
Category: Mercedes
Satisfied Customers: 3130
Experience:  Mercedes-Benz Master Certified technician
37243545
Type Your Mercedes Question Here...
Michael Warfield is online now
A new question is answered every 9 seconds

2000 ml320 150000 miles you can start it up it runs seconds

Customer Question

2000 ml320 150000 miles you can start it up it runs for 5 seconds then it cuts off and it won't start until you let it sit for an hour they told me to change the crank sensor I've done that still no start it still does the same thing
Submitted: 1 year ago.
Category: Mercedes
Expert:  Michael Warfield replied 1 year ago.

There is a DAS start authorization problem. It is usually a faulty key or bad All Activity Module. Sometimes the DAS module with immobilizer ring is faulty as well. I would start by trying a spare key, if you don't have one, order a new one from the dealership. If that doesn't work, at least you have a spare now. I would replace the All Activity Module that is attached to bottom of the fuse box under the hood.

Expert:  Michael Warfield replied 1 year ago.

Were you able to get any parts replaced on your ML?