How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, Mercedes Technician
Category: Mercedes
Satisfied Customers: 53780
Experience:  Bosch Certified Master Tech. Over 35 years experience.
13230946
Type Your Mercedes Question Here...
Marty is online now
A new question is answered every 9 seconds

Marty. Switch the line on the sl 500.. didn't blow

Customer Question

Hey marty. Switch the line on the sl 500.. didn't blow anything. Now I can't get the suspension to level out. New strut on front left . That's the lowest. Rt side is higher. Much higher. . Did the rodeo. Any ideas
Submitted: 1 year ago.
Category: Mercedes
Expert:  Marty replied 1 year ago.

Sorry for the wait I have been backed up at work. Are you getting anywhere with this? Did you try driving the car to see if it would level out?

Customer: replied 1 year ago.
not realy .. when u put into drive or reverse .. left side goes down to much and light comes to low to drive. Im have some bad luck with this.. no leaks though
Expert:  Marty replied 1 year ago.

Can you scan the ABC suspension system?

Customer: replied 1 year ago.
I will. Get the codes later to u..
Customer: replied 1 year ago.
Maybe the used rear solenoids are bad
Expert:  Marty replied 1 year ago.

That's what I am thinking. I'm thinking you may need to replace the valve blocks. Does the car drop when you turn it off and let it sit for an hour?

Customer: replied 1 year ago.
Gonna take a video of what it's doing as well
Customer: replied 1 year ago.
Not at all. Didn't move from last night
Expert:  Marty replied 1 year ago.

Ok, I'd also like to see the fault codes.

Customer: replied 1 year ago.
Ok
Expert:  Marty replied 1 year ago.

I'm going to be away until tomorrow morning.

Customer: replied 1 year ago.
No problem. I was able to raise all the struts. I'm having trouble with my autel maxis . There were some special functions I was able to access. But the scanner crashes. . Will get back to u at later time. Thks marty
Expert:  Marty replied 1 year ago.

You're quite welcome.

Customer: replied 1 year ago.
Hi Marty.. after trying to activate everything i can with scanner. this is where I'm at.. When u put the car in drive or reverse and move the car an inch the front rt drops 30 to 40 mm. Then when u shut it off it levels a little. You go to start it and the front right now levels completely with other struts. But as soon as u move vehicle again ,the front front drops again.. any clue?
Expert:  Marty replied 1 year ago.

Hi, it sounds like there may be a fault with one of the level sensors or with the acceleration sensors. Were you ever able to get any fault codes from the ABC system?

Customer: replied 1 year ago.
morning marty.. these are the codes i just pulled. swapped two front small solenoids last night.. same issue...
Customer: replied 1 year ago.
from the outside it doesn't sound like the front right strut is filling up with fluid.. when I open the bleeder screws.. all three except the rt front fluid comes out. When u open the rt front no fluid actually comes out.

Related Mercedes Questions