How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask FIXITMAN Your Own Question
FIXITMAN
FIXITMAN, Master Technician
Category: Mercedes
Satisfied Customers: 17218
Experience:  ASE MASTER CERTIFIED, AA DEGREE DIESEL/AUTOMOTIVE
1627031
Type Your Mercedes Question Here...
FIXITMAN is online now
A new question is answered every 9 seconds

I have a 2006 Mercedes ml500 I had a low voltage battery

Customer Question

Hi I have a 2006 Mercedes ml500 I had a low voltage battery service light come on the screen I changed both the battery and the alternator and when they tested the alternator the new one it showed the same reading like the old one low amperage of 12 volts and a I need a little help troubleshooting this issue
Submitted: 1 year ago.
Category: Mercedes
Customer: replied 1 year ago.
The battery terminals are fine there does not seem to be any loose ground wires in the battery compartment or the engine bay no corrosion...
Customer: replied 1 year ago.
I have checked all the fuses in the engine compartment in the trunk even in the battery compartment everything seems fine
Expert:  FIXITMAN replied 1 year ago.

Hello, thank you for the question. Can you tell me if the vehicle is now starting fine? Is the charging system light on when the engine is running?