How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Mercedes Mechanic
Category: Mercedes
Satisfied Customers: 24706
Experience:  Over 15 years experience as a Mercedes dealer technician
14928985
Type Your Mercedes Question Here...
Pete is online now
A new question is answered every 9 seconds

I have a 1997 Mercedes benz c230 2.3 4cyl. and injectors

Customer Question

I have a 1997 Mercedes benz c230 2.3 4cyl. and injectors will not spray fuel and when ignition switch is turned on injectors sprays for a moment and stop.
also ignition switch turns momentarily and stop. I have replaced throttle body ecm injector module fuel pump ignition switch, fuel filter and starter relay.
Submitted: 1 year ago.
Category: Mercedes
Customer: replied 1 year ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Customer: replied 1 year ago.
hello
Expert:  Pete replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

On some models this type of fault here can be caused by a faulty crank position sensor sending an incorrect signal.Usually this will cause a no start but it does affect the way the injectors operate.I would check the rpm signal on a scan tools data list when turning the key on and if it shows any kind of rpm signal on the scan tool data list with key on only and not cranking over the engine I suspect the crank sensor needs replaced.It should show a small rpm signal when cranking over the engine and if there is no signal on the scan tools data list when cranking over the engine I suspect the crank sensor needs replaced.If this is checked and found o.k. let me (Pete) know.

Thanks Pete