How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3740
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

1994 s500 .... driving fine out of no were battery light

Customer Question

1994 s500 .... driving fine out of no were battery light comes on goes into a limp mode.. shut car off restart and everything is is fine.. might do that 3 times in the course of a day.. i replaced the battery and checked the cables everything is fine..
the voltage at the battery at idle is 14.2 .. i ordered a new voltage regulator to see if that would work .. waiting for part in mail.. Any other suggestions?
Submitted: 1 year ago.
Category: Mercedes
Expert:  Lou P. master tech replied 1 year ago.

Hello. It definitely sounds like a power issue , it's possible the alternator is undercharging.do you have a meter that it's into the cigar lighter to tell the voltage ? You can buy those from almost any parts store they are great for road testing voltage issues , but this really sounds like a loose connection or alternator issue. It may be overcharging also which would put the system into a limp mode.