How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask FIXITMAN Your Own Question
FIXITMAN
FIXITMAN, Master Technician
Category: Mercedes
Satisfied Customers: 17143
Experience:  ASE MASTER CERTIFIED, AA DEGREE DIESEL/AUTOMOTIVE
1627031
Type Your Mercedes Question Here...
FIXITMAN is online now
A new question is answered every 9 seconds

I have a 2005 e 55 and I had a flat battery and I got a jump

Customer Question

I have a 2005 e 55 and I had a flat battery and I got a jump start using the rear battery
Now my radio won't come on and when I push the on button the screen displays the Mercedes emblem for about 30 seconds and then it switches off again by itself but I don't get any sound
Also my parktronic isn't working either
When I scroll down on my steering wheel to phone or navigation it just shows 4 dashes in a line
What is the problem?
Submitted: 1 year ago.
Category: Mercedes
Expert:  FIXITMAN replied 1 year ago.

Hello, my name is Bobby. Thank you for the question. If the voltage was very low in the system certain electronic systems will shut down. You need to start by having the battery load tested. If the battery is not holding enough of a charge this can occur. If the battery is fine then you may have a charging issue from the alternator or possibly an issue with the programming from the voltage loss.

Related Mercedes Questions