How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, Mercedes Technician
Category: Mercedes
Satisfied Customers: 53153
Experience:  Bosch Certified Master Tech. Over 35 years experience.
13230946
Type Your Mercedes Question Here...
Marty is online now
A new question is answered every 9 seconds

Chasing 560l Climate Control issues. I've replaced the

Customer Question

Chasing 560l Climate Control issues. I've replaced the actuator pods, verified hose routing, verified actuator pods work from the designated lines and are rock-solid tight at 600mb. The problem was that the pushbutton switch unit did not appear to be operating the center vents and defroster correctly, but the a/c was blowing cold on the side and lower vents. I replaced the pushbutton switch control unit (Programa reman) and the vents work correctly when the ignition is in run (but not started). When I start the car, I get full heat out of the vents, and the center vent is open (even when I push the defrost button). When I push the Econ (compressor off), the vents work correctly. I suspect I may need to replace the temperature control module as well. The outside temperature gauge is reading correctly, so I assume it must be connected correctly. Any suggestions?
Submitted: 1 year ago.
Category: Mercedes
Expert:  Marty replied 1 year ago.

Hi, welcome to Just Answer. My name is***** don't see how this could be a temperature control module problem. The Y34 vacuum switchover valve is controlled by the pushbutton switch. This has to be either a defective pushbutton switch or Y34 valve or the plugs on the pushbutton switch are reversed. This problem is too complicated to try and sort out in this format. I will need to talk to you on the phone for this problem. I've sent you an additional service agreement if you would like a phone call. If you accept the agreement I can call you in the morning.

Marty

Expert:  Marty replied 1 year ago.

Looks like the additional service tab is not working. I'll check with customer service and reply back.