How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Mercedes Mechanic
Category: Mercedes
Satisfied Customers: 27534
Experience:  Over 15 years experience as a Mercedes dealer technician
14928985
Type Your Mercedes Question Here...
Pete is online now
A new question is answered every 9 seconds

Have a 2002 mercedes c230 kompressor. 6 speed. Have two keys

Customer Question

Have a 2002 mercedes c230 kompressor. 6 speed. Have two keys neither will turn the car over, neither will lock/unlock/trunk. Both keys when turned all the way to the start position don't do anything but the fan comes on at high speed. All the electronics seem to work as they should. Battery was checked and is good. Previous owner added a new stereo, could he of messed something up with security device? Put new batteries in key fob. Still nothing. Took the starter relay out and jumped it and car turned over with key in the start position but had no spark.
Ok with that out of the way I bought the car not running. This was the problem it came with because previous owner was stumped and gave up on it. His story is that he was driving it and ran out of gas, limped it to the gas station and put gas in it, went to start it and nothing happened like stated above.
I have found receipts in the glove box that the front Sam was replaced in 2014. Any and all help would be grateful before I have no hair!
Submitted: 1 year ago.
Category: Mercedes
Expert:  Pete replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

One common component that can cause an issue like this here in some cases is the electronic ignition switch itself.I have seen this switch fail electronically and cause issues like this here needing replaced.If you have not had the fault codes checked in all computers this needs done and any codes set will need diagnosed to locate and correct this issue here.

Thanks Pete