How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask MB Paul Your Own Question
MB Paul
MB Paul, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3567
Experience:  Qualified Mercedes Benz Diagnostic Technician - 20+ years experience - Workshop Foreman for Mercedes
15777119
Type Your Mercedes Question Here...
MB Paul is online now
A new question is answered every 9 seconds

Have a 2004 ML 350 (120K miles) before engine is fully

Customer Question

Have a 2004 ML 350 (120K miles) before engine is fully warmed up...it runs great...then as it warms up....it starts to miss...some times dies...you know the drill: have now installed: all the engine sensor's...except for the "Cam senor"....sure; I plan on installing one. I'm I missing something? 120k miles...is there any other thing that I can do....? I did note; That after changing every senor except for the Cam senor that on test drive afterward: the car really felt strong....then it warmup: and started to miss and shut-down....question it they any upgrade parts....other than the normal parts house parts ?
Thanks for any help that you can give me Thom Meyers Bend, Oregon
Submitted: 1 year ago.
Category: Mercedes
Customer: replied 1 year ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Customer: replied 1 year ago.
Yeah: the only senor....that I have not yet changed....it the "CAM SENOR:
THOM
Expert:  Lou P. master tech replied 1 year ago.
Hello my name is ***** ***** i will do my best to help you , i strive for EXCELLENT service and nothing less. So has the problem occurred before or after changing any parts ? Or has nothing you changed improved it made it worse ? And can sensors on these engine don't usually go bad and when they do they don't cause this type of issue. This really sounds more fuel pump related.

Related Mercedes Questions