How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, Mercedes Technician
Category: Mercedes
Satisfied Customers: 53168
Experience:  Bosch Certified Master Tech. Over 35 years experience.
13230946
Type Your Mercedes Question Here...
Marty is online now
A new question is answered every 9 seconds

2003 e320 flares when shifting when warmed up. no problem

Customer Question

2003 e320 flares when shifting when warmed up. no problem when cold. dealer says fluid is "wicking" up cableand trans is o.k.. wires look dry inside engine compartment. may be unit on bottom of transmission?
Submitted: 1 year ago.
Category: Mercedes
Expert:  Marty replied 1 year ago.
Hi, if the fluid is wicking up the cable harness you will need to replace the 13 pin connector on the transmission. The part number is ***** 540 02 53. I would replace the connector and correct the fluid level in the transmission. It sounds like the fluid has gotten low due to the leak. If you still have trouble with slippage when the fluid is full you may need to rebuild the transmission. The speed sensors in the transmission can also give trouble but when they act up the transmission goes into limp home mode and does not shift at all.
Let me know if you have any questions.
Marty

Related Mercedes Questions