How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3740
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

S 430: Marty, this is my first time using something like

Customer Question

Hi Marty, this is my first time using something like this, however I hope your able to assist. Would be very greatful. I have a 2004 S430 Mercedes and I'm having trouble with the door locking mechanism. I read some post online changed out the pump which cost $300 and the lock system still not working. The pump runs and when I hit the lock/unlock button on the remote it sounds like its working but its not. I'm not sure if mine have that soft close feature but if it does that doesn't work also. I just bought the car 3 months ago knowing the power locks didnt work but I assumed it would be simple like a fuse which clearly isnt the case. Please if you can assist in anyway would be greatful
Submitted: 1 year ago.
Category: Mercedes
Expert:  Lou P. master tech replied 1 year ago.
Hello my name is ***** ***** i will do my best to help you , i strive for EXCELLENT service and nothing less. Sorry to hear you are having issues. This system is pretty easy to diagnose. In sure we can figure it out together. First off. Do ANY of the door locks work or trunk or soft close feature ? Where did you get the "new" pump from ?
Expert:  Lou P. master tech replied 1 year ago.
Are you still needing assistance ?
Customer: replied 1 year ago.
I purchased my pump off eBay and had it tested, the pump seems to work. If i push all the locks down into the lock position and use the unlock button it does unlock however there is no suction after hitting the lock button, I'm at a lost at this point.
Expert:  Lou P. master tech replied 1 year ago.
Ok if the locks all work one way but not the other the issue is the PSE pump. Regardless of what you think or have tested. The only explanation is the PSE pump. It's the same lines and same pump used for pressure and vacuum. Inside the pump housing are two rubber lines that come from the PSE for auction and vacuum and on the top of the pump is a cap that can break and cause loss of vacuum. Change the pump with new. Not used. That will fix the car. Please take a second and click the box and rate my service GOOD OR EXCELLENT SERVICE if you feel I have been helpful and please request me in the future. If you feel I have not been helpful please DO NOT RATE BAD OR POOR AND WASTE YOUR MONEY , I will opt out to see if another expert can provide more or better assistance so you're not wasting your money!!. Thanks for choosing just answer. Lou. also , if you feel i deserve one , BONUSES are GREATLY APPRECIATED ! 😉

Related Mercedes Questions