How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask FIXITMAN Your Own Question
FIXITMAN
FIXITMAN, Master Technician
Category: Mercedes
Satisfied Customers: 17143
Experience:  ASE MASTER CERTIFIED, AA DEGREE DIESEL/AUTOMOTIVE
1627031
Type Your Mercedes Question Here...
FIXITMAN is online now
A new question is answered every 9 seconds

SLK 230: I bought a 2002 SLK 230 that was in apparent good

Customer Question

I bought a 2002 SLK 230 that was in apparent good repair. Has 135k on it. New tires. When I drive it at normal speed it runs smooth as butter, but as soon as I give it some gas, it coughs and spits and has a rough idle that will imediately reset when I turn off the key and restart. The DTC codes are misfire on all 4 cylinders P0300-P03004 as well as speed semsor PO5000 The seller told me it needed a coil pack, butthat seems like it would be a constant problem. I inspected the K40 relay and did a thourough CRC cleaning of MAF which by the way was dry, no oil in the tube or the MAF. In researching this issue it is a common problem, however I havent seen a common repair. People go on forums and complain and describe exactly the same issue, but no one seems to have the answer. I don't mind replacing sensors or relays or plugs or coils, but I want to know what did what. Also, my coils just barely cover the spark plugs. In fact, when I was pulling the first for inspection I actually thought the plug was broken...
Submitted: 1 year ago.
Category: Mercedes
Expert:  FIXITMAN replied 1 year ago.
Hello, my name is Bobby. Thank you for the question. If you are getting misfires on all of the cylinders typically this is caused by a larger issue than a coil or spark plug. The MAF can be failing, but it also sounds like a fuel related issue. If the fuel pump is weak or if the fuel filter is old or dirty then this can occur. Since you do not know the history of the car I would change the fuel filter first to see if it helps.