How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask MB Paul Your Own Question
MB Paul
MB Paul, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3567
Experience:  Qualified Mercedes Benz Diagnostic Technician - 20+ years experience - Workshop Foreman for Mercedes
15777119
Type Your Mercedes Question Here...
MB Paul is online now
A new question is answered every 9 seconds

Ml320: 2009 Mercedes ml320 blutec--Occasionally looses power

Customer Question

2009 Mercedes ml320 blutec--Occasionally looses power while driving,, The transmission also seems to not shift properly. After 2 to 15 minutes it starts running normal. No engine lights.
Submitted: 1 year ago.
Category: Mercedes
Expert:  Billy replied 1 year ago.
Hello and Welcome! I'm Billy and i will assist you with your inquiry. Feel free to ask if any further info is needed.
Just to confirm, while driving normally, the engine looses power for a few minutes, and then gets normal again?
Did you check anything yet?
Are you getting no warning lights or messages on dash (apart from the engine)?
does it seem to happen more when cold, hot, traffic lights, when cruising, or is there no clear pattern to this?