How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask MB Paul Your Own Question
MB Paul
MB Paul, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3567
Experience:  Qualified Mercedes Benz Diagnostic Technician - 20+ years experience - Workshop Foreman for Mercedes
15777119
Type Your Mercedes Question Here...
MB Paul is online now
A new question is answered every 9 seconds

CL500: My 2002 CL500 started showing SRS light, ABC light,

Customer Question

My 2002 CL500 started showing SRS light, ABC light, Passenger Seat Stuck light, then the windshield wipers stopped working, then it started dying on the road with no electrical power, then it just stopped starting. Scope reads "Low Voltage", but other things don't show codes.
Submitted: 1 year ago.
Category: Mercedes
Customer: replied 1 year ago.
Checked battery posts - clean, but cleaned them again - cables are tight.
Checked all fuses - none burnt. Is there another Fuse box besides the main one under the hood up in the right - near the driver firewall?
Expert:  Lou P. master tech replied 1 year ago.
Hello my name is ***** ***** i will do my best to help you , i strive for EXCELLENT service and nothing less. Thanks for requesting me , you have a multitude of fuse boxes , what is the voltage of the car while running ?
There's a fuse box on left and right side of engine bay , right interior floor board , rear under passenger back seat , and fuse box in trunk behind panelling near the fender well. The floor board and fender well fuses are really huge amperage fuses from the battery to the fuse and relays they are called prefuse boxes.
The srs and abc are common to come on so I wouldn't count those to low voltage yet unless you have a code specifically for those modules , the windshield wipers could just be a faulty wiper switch depends on what works or doesn't work with the switch , and the car dying and not starting I would like to know more about. So does it currently not start ?