How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 4416
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

2008 Mercedes c300 sport...cooling fan running on high at all

Customer Question

2008 Mercedes c300 sport...cooling fan running on high at all times and ac compressor not coming on
Submitted: 1 year ago.
Category: Mercedes
Expert:  Lou P. master tech replied 1 year ago.
Hello my name is ***** ***** i will do my best to help you , i strive for EXCELLENT service and nothing less. Are you talking about the engine fan ? And is there a check engine light ?
Customer: replied 1 year ago.
Yes engine fan..I do have a ck light which is po410 but I had code before ac spot working
Expert:  Lou P. master tech replied 1 year ago.
Ok , these cars were prone to 2 issues , The cooling fan will short out and stay running or the ECM will short out and continue running the cooling fan for no reason,do you have a meter or test light ?
Customer: replied 1 year ago.
I have test light
Customer: replied 1 year ago.
Plug to compressor has no power
Expert:  Lou P. master tech replied 1 year ago.
Ok , sorry for the delay , not worried about the compressor yet , with the radiator fan plugged in and the car running so the fan is on , check the wiring , on the 2 small wires there should only be 1 with power. If both have power then the ECM is bad , the ECM is on the top center of the engine. If there is only power on 1 wire and the fan is running then the fan is at fault. Now the ECM is covered under 8yr 80k mike warranty if your still under that. Depends on when the car went into service meaning sold. So check the radiator fan wiring. Let me know.