How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, Mercedes Technician
Category: Mercedes
Satisfied Customers: 53152
Experience:  Bosch Certified Master Tech. Over 35 years experience.
13230946
Type Your Mercedes Question Here...
Marty is online now
A new question is answered every 9 seconds

2000 c230 power windows power mirrors, central locking and

Customer Question

2000 c230 power windows power mirrors, central locking and wipers all inop
Submitted: 1 year ago.
Category: Mercedes
Expert:  Lou P. master tech replied 1 year ago.
Hello my name is ***** ***** i will do my best to help you , i strive for EXCELLENT service and nothing less. I appreciate you requesting me. Did this all happen at the same time ? What have you done so far if anything to try and fix besides checking fuses ?
Expert:  Lou P. master tech replied 1 year ago.
There is no link between the locks and wipers so we will have to do some checking to find out what else does not work. Also the wipers will not work with the doors open or the hood open. Keep that in mind. And as far as the windows , do they work at all with the switches ? In short bursts or not at all?
Customer: replied 1 year ago.
window stopped working and central locking quit working, on the way home it rained and then realized the wipers werent working as well as turn signals, did a hard reset, disconnected batt and joined terms together , no change, is it possible front left sam is bad
Customer: replied 1 year ago.
windows do not work at all with front switches or rear door switches
Customer: replied 1 year ago.
also horn does not work
Customer: replied 1 year ago.
pulled lf sam and checked connections no corrosion noted
Expert:  Lou P. master tech replied 1 year ago.
Ok , see the Sam would affect the wipers and turn signals but not the windows or locks. That would be the rear Sam. Did all this start during the rain ?
Expert:  Lou P. master tech replied 1 year ago.
If it started due to the rain I'm thinking the CAN DATA BUS may be affected. Check for water on the drivers and passenger front floor to see if it's damp
Customer: replied 1 year ago.
were in sw florida and this is the rainy season drove home yesterday in the rain, window went down this morning and wouldnt go up when my wife got to work. and the locks wouldnt lock didnt know whether the turn signals were down or not. didnt try the wipers untill the ride home
Customer: replied 1 year ago.
carpet is dry on both sides
Expert:  Lou P. master tech replied 1 year ago.
Ok , you may have to pull the passenger front carpet back it's pretty easy , there will be a foam board behind there and a metal plate that is held down with 3 10mm nuts. Need to make sure there is no water , you will see a bunch of brown wires going into the same connector, they are located on the under dash panels on drivers and passengers side , also may be on the body (A-pillar) on left and right side , and if the windshield was ever replaced or if the air filter box over the battery was not put in correctly water can intrude and once the communication lines get wet it takes down all interior functions. So since the rain is the possibility since that's when it seemed to happen , so we need to 1000% verify
Customer: replied 1 year ago.
battery is in trunk
Expert:  Lou P. master tech replied 1 year ago.
Oh sorry correct. The w202 body stopped in 2000 sorry. Ok , I was thinking of the 01' w203. So sorry.
Expert:  Lou P. master tech replied 1 year ago.
Is the red light on the trunk switch lit up? Can you pop the trunk with the button in the console ?
Customer: replied 1 year ago.
no light on trunk switch and it does not work
Customer: replied 1 year ago.
pulled the carpet and undid the metal plate, has a siemens biult module with 2 connectors remove and checked for moisture none preasent and floor is bone dry
Expert:  Lou P. master tech replied 1 year ago.
Ok. So the wood trim around the shifter comes up pretty easy. First pull up the grey trim around the shifter , then you can pull up the wood trim it just pops up. Then the window switch assembly will unsnap from the wood, unplug the connections and see if there is water traces on the switches.
Customer: replied 1 year ago.
have that out already no signs of water and the wife says she did not spill anything in there, asked her twice
Expert:  Lou P. master tech replied 1 year ago.
Ok ok , i would need some time to go over some diagrams to see what the issue could be that connects all the issues , if you are able to wait until tonight I will still assist. If you need faster answers I will opt out so maybe another expert may be able to assist further. Let me know how you wish to proceed
Customer: replied 1 year ago.
how long i have about another hour of day light left
Customer: replied 1 year ago.
there has to be a common denominator for all these things to go out at once this car has no issues like this untill now
Expert:  Lou P. master tech replied 1 year ago.
Would take longer than that. Mainly cause it rained bad here in Illinois so at the time I'm forced to use my tablet , need to boot up the desktop now that's the storms are passing. I will opt out. And I will continue to work on your issue even if another expert starts to help. And if I find something I will let you know , hopefully another expert opts in.
Customer: replied 1 year ago.
not satisfied with response so far, you have not provided me with any usable info and im through for the night
Expert:  Marty replied 1 year ago.
Hi, perhaps I can help. My name is***** the key on and test for battery voltage at fuse 20 and 22. If you have no voltage at the fuses you have a bad ignition switch.
Let me know what you find out.
Marty
Customer: replied 1 year ago.
just got your message wife took car to work will check this eve 20 and 21 are in the lf under hood fuse box
Customer: replied 1 year ago.
cant mess around to much longer with the car may have to take to a shop north of where i am
Expert:  Marty replied 1 year ago.
Yes the fuses are in the left front fuse box under the hood. 20 and 22 are the fuses that need testing.
Let me know what you find out.
Marty
Customer: replied 1 year ago.
both fuse have power on both sides
Customer: replied 1 year ago.
some of the inop systems started working on the ride home all except the windows however right now none of the systems mentioned originally are working now
Expert:  Marty replied 1 year ago.
Let's try rebooting the controller area network. To do this you need to disconnect both battery cables and jump the two cable ends together for 5 minutes then remove the jumper and reconnect the cables to the battery then see if everything works.
Customer: replied 1 year ago.
did that last night but maybe not for 5 minutes
Expert:  Marty replied 1 year ago.
Ok, most likely you have a bad window motor and it is bringing down the entire interior network. You will need to disconnect one motor at a time until the network comes back online. Once you locate the bad motor you can reconnect the others and everything but the bad motor will operate. The motors can be disconnected from the CAN bus connector located under the passenger side front door sill or floor area. Copy and paste the link below for the approximate location. Sometimes you have to do a little hunting for the connector. The connector will have 7 or 8 pairs of brown and brown/red wires. All of the network components connect there. Disconnect one at a time then turn the key on and see if everything starts working. Work your way through the connector until you find the component that is bringing the network down.
http://www.mediafire.com/view/a86p3nxie17hdw2/Capture.PNG
Let me know what you find.
Marty
Customer: replied 1 year ago.
got the turn signals and wipers working, no windows no central locking
Customer: replied 1 year ago.
have 2 connectors out of bus with either of those out the t/signals worked
Expert:  Marty replied 1 year ago.
Do the rear windows work from the rear seat switches?
Customer: replied 1 year ago.
no
Expert:  Marty replied 1 year ago.
I'd disconnect the PSE module in the trunk then see if you can plug in one or both of the bus connectors and see if everything but the locks work. It looks like you may have a bad PSE module and possibly a bad lower control panel. Does the sunroof work?
Customer: replied 1 year ago.
sun roof is working currently, which is the pse module?
Expert:  Marty replied 1 year ago.
The PSE module if the vacuum pump for the locks located in the right hand side of the trunk behind the paneling.