How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kevin Your Own Question
Kevin
Kevin, Master tech
Category: Mercedes
Satisfied Customers: 1724
Experience:  Diagnostic technician
84635724
Type Your Mercedes Question Here...
Kevin is online now
A new question is answered every 9 seconds

I have a 3.0d ML350 Bluetec. is telling me to add the

Customer Question

hi i have a 3.0d ML350 Bluetec. is telling me to add the blutec liquid but we already did. how to do we reset the light
Submitted: 1 year ago.
Category: Mercedes
Customer: replied 1 year ago.
we did the service and the service light have been reset. we 342 day to next service.
Expert:  Kevin replied 1 year ago.
Have you driven car since . It normally takes about 15 miles of driving for the car to relearn level there is not reset if the car doesn't turn light out after this time it will have an issue with tank level sensor
Customer: replied 1 year ago.
hi when u say 15 mile its about 30 kms right.
we haven't drive for more than 10 km.
the owner put 20l is that enough
Expert:  Kevin replied 1 year ago.
That amount should be fine yeah around 30 km it should go out on its own
Customer: replied 1 year ago.
is that also normal that the engine light comes on because of the liquid
Customer: replied 1 year ago.
im going for a test drive with the car comeback soon
Expert:  Kevin replied 1 year ago.
If this doesn't turn light out it is likely there is another fault with adblue system preventing reset
Customer: replied 1 year ago.
hi i went for a test drive with the car and light stays on its telling me that only have 753 km do drive no more.
the fault code i have is B127755
Expert:  Kevin replied 1 year ago.
The fault code doesn't appear to be listed on any lists I have it may be unique to your scanner there is obviously another fault in system preventing reset from occuring