How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3740
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

560SL: I have a 1988 560SL that is missing in one cylinder,

Customer Question

I have a 1988 560SL that is missing in one cylinder, spark to plug and fuel to injector, new wire, distributor cap and rotator, new injector, cam lobs are ok, compressor in cylinder ok. Why the miss?
Submitted: 1 year ago.
Category: Mercedes
Expert:  Lou P. master tech replied 1 year ago.
Hello my name is ***** ***** i will do my best to help you , i strive for EXCELLENT service and nothing less. Have you swapped the injector to another cylinder or have you physically seen it spray fuel ?
Customer: replied 1 year ago.
Yes, injector sprays in a nice cone spray. Has spark to injector and plug.
Expert:  Lou P. master tech replied 1 year ago.
Ok , are you pulling the spark plug wire off to determine if the cylinder is the one that is misfiring ? Like watching the rpm or engine change?
Customer: replied 1 year ago.
Yes, that is how I determined which cylinder it was.
Expert:  Lou P. master tech replied 1 year ago.
Ok well let's start over , cause you can't have air , fuel , compression, and spark and still have a dead cylinder. So something was overlooked.
So with all the new parts the only thing I can think is the compression is off.
Also did you check the firing order to make sure the wires are on the right cylinders ?
What was the compression reading and how did you do the compression test and how did it compare to all cylinders ?