How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3726
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

350 bluetec: well lou, I guess will try this again perhaps,

Customer Question

well lou, I guess will try this again perhaps, you will be able to answer..... no computer\fault codes, r350 cranks will not start when hot.... cranks and starts when cold.... the following has been done ....crankshaft position sensor has been replaced, fuel pump in tank has been replaced, MB replaced the distributing rail, will only guarantee their work if entire fuel system is replaced... my next step is to replace the camshaft position sensor..... battery was replaced in February, was serviced at 90,000 miles at MB now has 92500, replaced fuel filter at 92500.... once vehicle starts runs fine no hestation, no misfires, goes through gear changes no problem, acceleration no problem...so unless you have a rabbit you can pull out of your hat....
Submitted: 1 year ago.
Category: Mercedes
Expert:  Lou P. master tech replied 1 year ago.
Hello my name is ***** ***** i will do my best to help you , i strive for EXCELLENT service and nothing less. I really do appreciate you requesting me. Just for reference I only get paid when you accept my answer. We don't disclose this with customers but now you are requesting my assistance but never accepted my last answer. I understand the crank sensor may have not helped but you never responded to my last answer or suggestion. I go to great lengths to assist customers and will do what I can for you to walk away satisfied but I'm not sure how to proceed knowing that the last time the question was closed before my answer was accepted. Let me know how you wish to proceed.
Customer: replied 1 year ago.
Unfortunately, u were not the original mechanic who took the question,evidently he could not answer....the vehicle was then dropped off at the shop so an answer if there was one was not timely....it goes back to the shop in the morning to replace the camshaft position sensor...
Expert:  Lou P. master tech replied 1 year ago.
Ok , so do you want to wait until after the cam sensor replaced ? Or what ? I don't think it will help.
Mind if I ask you a few questions ?
Customer: replied 1 year ago.
When hot if i add a little brake fluid cleaner into air intake starts right up....
Customer: replied 1 year ago.
I agree will probably not help....but is only other sensor that sits right on the motor and takes a lot of heat.....when engine is cool cranks and starts within 5 seconds....it acts as if its not getting fuel
Customer: replied 1 year ago.
Ask away
Customer: replied 1 year ago.
What questions were u going to ask
Expert:  Lou P. master tech replied 1 year ago.
Ok , how long does it have to run before it won't start ?
And when it gets to that temperature can you simply shut the car off and then try right away and it won't start ? Or does it have to sit in the off position for a few minutes before it won't start ?
Expert:  Lou P. master tech replied 1 year ago.
Do you not work on the car yourself ? If we needed to try a few things do you have the tools to do so ? Air compressor ? Torx sockets ?
Customer: replied 1 year ago.
I had my wife take it to my daughters 3 miles away.....she stayed about 45 minutes came out ....crank no start tried 4 times....i told her to stop i did not want her draining battery....i went over about an hour later crank no start battery at 12.71v
Customer: replied 1 year ago.
I tried 3 times no start...4th time i added brake cleaner fluid in to air intake...crank and started 5 secs
Customer: replied 1 year ago.
Yes i have tools/ air compressor
Expert:  Lou P. master tech replied 1 year ago.
Does your r class have the air shocks all the way around ? Or just rear air? Are there ANY warnings on the dash when this happens ? Does the dash actually display info and gauges work when this happens ? How often does this happen ?
Customer: replied 1 year ago.
Air in rear.....no warnings.....all guages come up normal
Expert:  Lou P. master tech replied 1 year ago.
Ok. Well for a issue like this. Two major things you will need to fix this and diagnose it without a scan tool. A freezer and a blow drier. If you think the cam sensor may affect it , heat it up with a blow drier. Or wait till it acts up and remove the sensor and put it in the freezer for 10 minutes and reinstall see if it starts. If the vehicle can sit longer than 30 minutes and not start then 10 minutes should be enough time to cool it down. Or if you have a meter you ohm the terminals and write down the numbers then when it won't start you ohm them again and see how much they differ.
Customer: replied 1 year ago.
This happens everyday....wife will not drive as is not reliable starts in the morning ..no problem....drives into town to grocery store parks comes out cranks no start....i go into town add brake fluid cleaner cranks right up she comes home that has happened twice last couple moths
Customer: replied 1 year ago.
She no longer drives mb instead she is using company expedition
Expert:  Lou P. master tech replied 1 year ago.
From memory , the crank sensor and fuel pressure or fuel temperature sensor would be the ones to cause this. But you say that the crank sensor was replaced also the fuel rail which houses the pressure sensor. I believe the temp sensor is in the high pressure fuel pump. I would have to double check in the morning. I don't have access to that currently.
Customer: replied 1 year ago.
Thats why i thought replacing crank sensoe would solve it did not.....facing engine they replaced the right rail
Expert:  Lou P. master tech replied 1 year ago.
Ok so are they not able to diagnose it either ? Or are they just replacing parts off of your suggestions ?
Customer: replied 1 year ago.
They have no idea....except to replace entire fuel system....no faults....nothing wrong...i sent old fuel rail to a friend in germany...his brother is mb engineer....they sent part to mb lab and said checked out within paramters
Expert:  Lou P. master tech replied 1 year ago.
Ok I personally have only had crank sensors cause this. BUT being temperature related this should be easy to find. But it does not happen everyday ? You said in one reply that it happens everyday but at the end said it happened twice in a month ? Can you clear this up ?
Expert:  Lou P. master tech replied 1 year ago.
When was fuel filter ever replaced ? It may have nothing to do with it just want to cover the basics. If I ask a question that makes no sense to you believe me it will help me get a overall picture of what may be going on. Is the r class running now ? Like literally ? Can you make it not run while we are chatting ?
Oh and does the vehicle ever DIE while running ?
Customer: replied 1 year ago.
Both times she drove this occurred....its been in garage fo the last 6 weeks.....i made her take it today as the crank sensor was replaced last friday.....she will not drive it...i got a told you so when it would not start this afternoon....
Customer: replied 1 year ago.
Fuel filter was replaced same time rail was replaced has less then 50miles on it....never dies.....
Expert:  Lou P. master tech replied 1 year ago.
Ah, the ever so hurtful I told you so. I feel you man lol.
Expert:  Lou P. master tech replied 1 year ago.
Ok , so spraying brake clean helps it start ..... Why ,,,,, is the question.
Customer: replied 1 year ago.
She would rather drive the expedition even though she has to climb to get in.....its reliable......i have no idea but thats safer then ether
Expert:  Lou P. master tech replied 1 year ago.
Ok so it's not a sensor. Spraying brake clean would not change a sensor flaking out. Only change what some sensors read ...... Let me try to rephrase that
Customer: replied 1 year ago.
I have a dozen tractors for my pecan orchards.....when its cold we use brake cleaner fluid rather than ether....some people do not understand a little goes a long way...
Expert:  Lou P. master tech replied 1 year ago.
No I understand the spraying. I'm trying to wrap my head around what it is affecting to help it start.
Customer: replied 1 year ago.
U may be on to something there.....the cleaner comes out of the can under pressure....its cold or cool i then walked around hit the start it cranks then starts
Customer: replied 1 year ago.
Is there a temp sensor in the air intake????
Expert:  Lou P. master tech replied 1 year ago.
Like the ECM will only allowSo much fuel to spray when cranking , so adding extra fuel is helping the mixture ignite , allowing the ECM to take over injection quantity allowing it to run.
Expert:  Lou P. master tech replied 1 year ago.
Where are you spraying into ?
Customer: replied 1 year ago.
The 3 or 4 times i have used it always cranked and started within 5 sec
Customer: replied 1 year ago.
Right side airintake at grill
Expert:  Lou P. master tech replied 1 year ago.
Ok so you are not physically removing anything ?
Customer: replied 1 year ago.
No
Expert:  Lou P. master tech replied 1 year ago.
If you see a timer from the site in your end ignore it. We can continue even if it runs out.
Customer: replied 1 year ago.
Ok
Expert:  Lou P. master tech replied 1 year ago.
Ok , so can you try to get it to fail as we speak ?
Customer: replied 1 year ago.
I will go out and see if it cranks....starts
Customer: replied 1 year ago.
Second crank it started
Customer: replied 1 year ago.
So was about 3 hours from when she drove it home
Customer: replied 1 year ago.
I will let it run 10 minutrs shut it off see if it will start
Expert:  Lou P. master tech replied 1 year ago.
Oh so it just failed today also ?
Expert:  Lou P. master tech replied 1 year ago.
The fuel pump that was replaced , was it the in tank fuel Pump or the high pressure pump on the front of the engine ?
Customer: replied 1 year ago.
Not really, can hardly wait 3 hrs everytime to see if it starts
Customer: replied 1 year ago.
Fuel pump in the tank
Expert:  Lou P. master tech replied 1 year ago.
Ok so its still running at this time ?
Customer: replied 1 year ago.
After mb replaced rail and then i find nothing wrong with it.....i am skeptical of their mechanics.
Customer: replied 1 year ago.
Yes still running actually ....purring
Expert:  Lou P. master tech replied 1 year ago.
Well give them the benefit of the doubt. Is this under warranty or are you paying for it ?
Customer: replied 1 year ago.
I am paying
Customer: replied 1 year ago.
Thats about 3 miles
Customer: replied 1 year ago.
Just shut it down
Expert:  Lou P. master tech replied 1 year ago.
See if you come to the shop and its under warranty we at least replace something , if we cannot find or duicate the issue that way it's at least ruled out. But hard to do when the customer had to pay for it cause that's wasted money
Customer: replied 1 year ago.
Will now attempt to start
Customer: replied 1 year ago.
Cranked and started within 5 seconds
Customer: replied 1 year ago.
Could we be losing pressure?????
Expert:  Lou P. master tech replied 1 year ago.
Ok so it's making a liar out of you right now lol. Got to love cars man. I deal with this everyday. Ok well make sure temp on the dash is up to 80 where it should roughly be sometimes hotter , then let it sit off for about 10 minutes and then see if it starts. I'll get emails when you reply. I'm trying to think of things we can try when it fails.
Expert:  Lou P. master tech replied 1 year ago.
I was thinking of losing pressure but if the fuel pump in tank was replaced then that should have fixed it
Expert:  Lou P. master tech replied 1 year ago.
Ok also , here's what I don't get. A few shots of spray should not help. Here's why.
Expert:  Lou P. master tech replied 1 year ago.
The air comes in the intake tube , straight to a air filter (one on each side of engine ) then from the air filter to the turbo , then out a pipe to a muffler then through the inter cooler back up to a throttle plate then passed intake manifold runners into the intake then the valves then the cylinder. I find it hard to believe a few sprays make it all that way without dissipating or mixing with all that air to dilute it.
Expert:  Lou P. master tech replied 1 year ago.
For me to believe that helps , I would crank the car. And crank two to three times if it doesn't start. Then start cranking and as it cranks give it a shot into the intake and see if it then fires up. That would help me believe that the starter spray helps.
Expert:  Lou P. master tech replied 1 year ago.
If you turn the key to start and let it go it will crank on its own for about 5-8 seconds. If you turn and hold the key in crank it will crank as long as you hold it. Unsure if you are aware of this.
Customer: replied 1 year ago.
Just use the button
Expert:  Lou P. master tech replied 1 year ago.
Oh you have the push start , you can actually pull that button out. It's just plastic. It's nothing. Then you can use the key.
Customer: replied 1 year ago.
Went to daughters and back ....shut it diwn will try to start
Customer: replied 1 year ago.
4 cranks no start
Customer: replied 1 year ago.
4 crabks using key no start
Expert:  Lou P. master tech replied 1 year ago.
Ok spray your magic
Customer: replied 1 year ago.
This time did not work
Customer: replied 1 year ago.
7 cranks no start
Expert:  Lou P. master tech replied 1 year ago.
Ok. That tells me was a coincidence. Now turn the key on to the second click and then off and repeat about 4 times giving 5 seconds between each off/on sequence then see if it starts.
Customer: replied 1 year ago.
No start
Expert:  Lou P. master tech replied 1 year ago.
Ok turn key on , all dash lights ok ? Everything comes to life on the dash ? Do you hear the fuel pump buzz?
Customer: replied 1 year ago.
Yes
Expert:  Lou P. master tech replied 1 year ago.
Ok , so you have a second person to help?
Customer: replied 1 year ago.
Not tonight
Customer: replied 1 year ago.
Give me a list on things to check and i will have one of my employees to help in the morning.....its past my bedtime
Expert:  Lou P. master tech replied 1 year ago.
iOk at this point the best I can say to check is the front fuse box. There have been issues of the box burning internally. If you open the hood and look to the left its the black box with two tabs to open it up in front. So open the box and try wiggling or tapping on the box to see if it comes to life. The good thing is that you can get the car to die. So if you do bring it to the dealer tell them or stay with them to get the car to die and not restart and then it should be easy to find the sensor or relay that is not working. But if you can check the fuse box that is what think should be ruled out since I have seen more and more issues with these. That's the best I can do right now man. Wish I had the magic answer. If you don't decide to go to dealer you can try unplugging sensors one at a time and see if it will start. The computer will allow a engine to start with a unplugged sensor which is the easiest way to diagnose a failed sensor. It will cause a check engine left so you know. The upper engine cover is easy to remove also the sheet metal above it. If you choose to do more on your own I will do what I can to help. So until tomorrow. Lou. Please take a second and click the box and rate my service GOOD OR EXCELLENT SERVICE if you feel I have been helpful and please request me in the future. If you feel I have not been helpful please DO NOT RATE BAD OR POOR AND WASTE YOUR MONEY , I will opt out to see if another expert can provide more or better assistance so you're not wasting your money!!. Thanks for choosing just answer. Lou. also , if you feel i deserve one , BONUSES are GREATLY APPRECIATED ! 😉 Keep in mind then when you rate it does not end our conversation. you can still return here to me for follow up information if needed, Lou.
Expert:  Lou P. master tech replied 1 year ago.
checking back? any luck ?