How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, Mercedes Technician
Category: Mercedes
Satisfied Customers: 53168
Experience:  Bosch Certified Master Tech. Over 35 years experience.
13230946
Type Your Mercedes Question Here...
Marty is online now
A new question is answered every 9 seconds

C240: 2003 c240 replaced fuel pump in January with bosch0986580342

Customer Question

2003 c240 replaced fuel pump in January with bosch0986580342 and just yesterday took the pump and sending unit on the left out. I noticed the right side had over 1/3 fuel and the left side 0 (empty) and cleanned the 5prons connector and i got power to the pump i installed the pump and sender car ran ok . i put more gas and drive it around, stop restart etc, seemed ok. This morning would not start. No codes. Why is no fuel on the left side of the tank and i didnt replace the sending unit on the left! I did replace the relay.
The car would not start now no fuel
Submitted: 1 year ago.
Category: Mercedes
Expert:  Marty replied 1 year ago.
Hi, welcome to Just Answer. My name is***** fuel returns back to the tank it enters on the left side and is forced over to the right side via a jet pump. If the hose that connects the left side sender to the right side pump is disconnected or kinked it will cause this problem. If the new fuel pump is weak and cannot force fuel through the jet pump over to the right side it will also cause the problem. I'd start by removing the left and right side units and inspecting the fuel line between the two.
Let me know if you have any questions.
Marty

Related Mercedes Questions