How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Mercedes Mechanic
Category: Mercedes
Satisfied Customers: 26254
Experience:  Over 15 years experience as a Mercedes dealer technician
14928985
Type Your Mercedes Question Here...
Pete is online now
A new question is answered every 9 seconds

I have a 2009 smart car with 95,000 miles on it. I just recently

Customer Question

I have a 2009 smart car with 95,000 miles on it. I just recently bought it and noticed that the exhaust is sputtering. It's only on Idol it's just chugging out of exhaust. No smoke but I don't think it's normal and I have no ideas what it could be.
Submitted: 1 year ago.
Category: Mercedes
Expert:  Pete replied 1 year ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
In some cases a small exhaust leak allowing air to enter the exhaust system will cause the sputter as well as partially restricted fuel injectors not atomizing the fuel properly.If the check engine light has not come on then it isn't a major fault and you can leave it as it is and drive it as long as it operates properly or have it looked into further to see which is the cause here.In some cases adding injector cleaner to the fuel tank will clean up restricted injectors.
Thanks Pete
Customer: replied 1 year ago.
Thank you Pete. I replace the spark plugs and it did absolutely nothing. I thought it might be the coil but I haven't ordered them because it will be about 600 in parts. The exhaust spudders and the motor shakes bad. Shakes the car. It gets worse the longer it idols. It is also very sluggish in first and second gear. My new recent issue was today I put the car in reverse and it would engage or drive. It kept blinking that it was in neutral. I looked online and they said there's a software update and I would also have to replace certain parts because it smells like the transmission clutch is burning when i drive. Do you have any input on that issue. I feel like I bought a lemon
Expert:  Pete replied 1 year ago.
I apologize for the delay as I was off line the last few days.
Your welcome
I don't see anything myself on the transmission issue here,this may be a fault with the control module and shift solenoids needing programmed and some solenoids replaced or an issue with the transmission valve body itself needing replaced.This will need to be tested further to pinpoint the cause and then repaired from there.
Thanks Pete