How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, Mercedes Technician
Category: Mercedes
Satisfied Customers: 53159
Experience:  Bosch Certified Master Tech. Over 35 years experience.
13230946
Type Your Mercedes Question Here...
Marty is online now
A new question is answered every 9 seconds

560 sl: My 89 560 Sl has a working ac system. However, while

Customer Question

My 89 560 Sl has a working ac system.
However, while driving down the road it may shut off. It may come back on the the selections switches are pushed off then back to on. Sometime pushing the windshield defrost button and then back to the AC button will result in the AC restarting. Any ideas????
Submitted: 1 year ago.
Category: Mercedes
Expert:  Marty replied 1 year ago.
Hi, can you tell me exactly what happens? Does it just stop blowing cold air or does it stop blowing air altogether?
Marty
Customer: replied 1 year ago.
It stops blowing completely. Pushing the defrost button will start the defroster blowing and then, sometimes, pushing the AC button next will result in the AC starting again with cold air. After stopping the car and turning off the ignition the AC will come on again either by pushing the AC button or if the AC button was left in the on position when the ignition was turned off.
Expert:  Marty replied 1 year ago.
Ok, that sounds like a bad pushbutton switch. You should check the fuse connections but since you can bring the blower to high speed by pressing the defrost button I suspect that there is a problem with the circuit board in the switch. Fuse 6 and 7 power the climate control. A bad ignition switch could also cause the problem but if the ignition switch were the problem you wouldn't be able to get the blower to come on by pressing the defroster switch. You could try nudging the ignition switch a little towards off and see if the blower will come on. This sounds most like a bad pushbutton switch. Usually you can remove the switch and flex the switch by grabbing it at the connectors and get it to stop or start working. That's a sure sign that the switch is bad.
Let me know if you have any questions.
Marty