How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask MB Paul Your Own Question
MB Paul
MB Paul, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3567
Experience:  Qualified Mercedes Benz Diagnostic Technician - 20+ years experience - Workshop Foreman for Mercedes
15777119
Type Your Mercedes Question Here...
MB Paul is online now
A new question is answered every 9 seconds

I have a problem with my 1986 560sl. After I replace the

Customer Question

I have a problem with my 1986 560sl. After I replace the Timing chain and guides it ie will crank but not start. If I put fuel into the fuel dish air intake it starts immediately and run for a few seconds. After several test I replaced the fuel pumps,filter and now I have a flow rate of 1 liter in 30 seconds going to the fuel pressure regulator, but no fuel out of the regulator to the distributor. I conntced a inline guage between the pumps and the regulator and I have excess do 90psi into it.
Submitted: 1 year ago.
Category: Mercedes
Expert:  Marty replied 1 year ago.
Hi, welcome to Just Answer. My name is***** sounds like you have the fuel lines reversed at the valve cover. Fuel from the tank goes directly into the fitting on the fuel distributor and returns back to the tank from the regulator. Try reversing the two lines at the valve cover and see if it fires.

Let me know how you make out.

Marty