How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Mercedes Mechanic
Category: Mercedes
Satisfied Customers: 24657
Experience:  Over 15 years experience as a Mercedes dealer technician
14928985
Type Your Mercedes Question Here...
Pete is online now
A new question is answered every 9 seconds

My 2004 ml350 radio just quit making sound. It had been previously

Customer Question

My 2004 ml350 radio just quit making sound. It had been previously repaired because the chip wouldn't accept the code. It came back with a new code, but would not put out sound until I cleaned the fiber optic connection. I just cleaned again but no sound. I noticed only one side of of connector in the radio has light on.
Submitted: 1 year ago.
Category: Mercedes
Expert:  Pete replied 1 year ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
You will only have one light in the fiber connector as this light loops through the radio and the radio sends the light back through the other fiber cable in the connector.
The most common cause for no sound is the sound amplifier itself failing.I have seen the amplifier fail several times before in the past and had to replace it for this exact issue here.If this sound issue was not a problem until the radio was repaired then the radio itself has an internal fault that was not repaired properly and needs re checked and repaired again.
Thanks Pete